抽屉原理-sum

Given a sequence, you’re asked whether there exists a consecutive subsequence whose sum is divisible by m. output YES, otherwise output NO

    Input
    The first line of the input has an integer T (1≤T≤101≤T≤10), which represents the number of test cases. 

For each test case, there are two lines:

1.The first line contains two positive integers n, m (1≤n≤1000001≤n≤100000, 1≤m≤50001≤m≤5000).

2.The second line contains n positive integers x (1≤x≤1001≤x≤100) according to the sequence.

    Output
    Output T lines, each line print a YES or NO.

    Sample Input
    2

3 3
1 2 3
5 7
6 6 6 6 6

    Sample Output
    YES

NO

现在假设有一个正整数序列a1,a2,a3,a4……an,试证明我们一定能够找到一段连续的序列和,让这个和是n的倍数,该命题的证明就用到了抽屉原理
我们可以先构造一个序列si=a1+a2+…ai
然后分别对于si取模,如果其中有一个sk%n==0,那么a1+a2+…+ak就一定是n的倍数(该种情况得证)
下面是上一种情况的反面,即任何一个sk对于n的余数都不为0
对于这种情况,我们可以如下考虑,因为si%n!=0
那么si%n的范围必然在1——(n-1),所以原序列si就产生了n个范围在1——(n-1)的余数,于是抽屉原理就来了,n个数放进n-1个盒子里面,必然至少有两个余数会重复,那么这两个sk1,sk2之差必然是n的倍数,
而sk1-sk2是一段连续的序列,那么原命题就得到了证明了

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

int main()
{
    int t;
    scanf("%d", &t);

while(t--)
    {
        int n, m, sum, num, flag = 0;
        bool vis[5005];

scanf("%d%d", &n, &m);
        memset(vis, false, sizeof(vis));
        sum = 0;
        vis[0] = 1;
        for(int i = 1; i <= n; i++)
        {
            scanf("%d", &num);
            sum += num;
            if(vis[sum%m]) flag = 1;
            vis[sum%m] = true;
        }

 if(flag)
            printf("YES\n");
        else
            printf("NO\n");
    }

 return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值