10010Recaman’s Sequence

Recaman’s Sequence
Time Limit: 1000ms, Special Time Limit:2500ms, Memory Limit:65536KB
Total submit users: 1252, Accepted users: 1085
Problem 10010 : No special judgement
Problem description
The Recaman’s sequence is defined by a0 = 0 ; for m > 0, am = am−1 − m if the rsulting am is positive and not already in the sequence, otherwise am = am−1 + m.
The first few numbers in the Recaman’s Sequence is 0, 1, 3, 6, 2, 7, 13, 20, 12, 21, 11, 22, 10, 23, 9 …
Given k, your task is to calculate ak.
Input
The input consists of several test cases. Each line of the input contains an integer k where 0 <= k <= 500000. The last line contains an integer −1, which should not be processed.
Output
For each k given in the input, print one line containing ak to the output.
Sample Input
7
10000
-1
Sample Output
20
18658
Problem Source
Shanghai-P 2004

#include<stdio.h>
#include<iostream>
using namespace std;
int main()
{
	int a[500001];
	bool b[10000000]={0};
	a[0]=0;
	b[0]=1;
	for(int i=1;i<500001;++i)
	{
		int n=a[i-1]-i;
		if(n<0||b[n])n=a[i-1]+i;
		b[n]=1;
		a[i]=n;
	}
	int k;
	while((cin>>k)&&(k+1))
	{
		cout<<a[k]<<endl;
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值