Can you find it?

Can you find it?

Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.

Input

There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.

Output

For each case, firstly you have to print the case number as the form “Case d:”, then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print “YES”, otherwise print “NO”.

Sample Input

3 3 3
1 2 3
1 2 3
1 2 3
3
1
4
10

Sample Output

Case 1:
NO
YES
NO
一.题解及分析

这个题目用四层循环肯定超时,故需要先将前两组数据加起来再排序,然后利用二分法具体如下:

  1. sum1=L+M
  2. 对sum1进行排序
  3. 二分查找
# include<math.h>//B Can you find it?
#include<algorithm>
using namespace std;
#include<stdio.h>
int main()
{ 
    int a,b,c,d=1;
    while(scanf("%d%d%d",&a,&b,&c)==3)//或 while(~scanf("%d%d%d",&a,&b,&c))
    {
        int s,y=0,t,m=0,num=0;
        int L[500]={0},M[500]={0},N[500]={0},sum1[250000]={0};
        for(int i=0;i<a;i++)
        {
            scanf("%d",&L[i]);
        }
        for(int i=0;i<b;i++)
        {
            scanf("%d",&M[i]);
        }
        for(int i=0;i<c;i++)
        {
            scanf("%d",&N[i]);
        }
        for(int i=0;i<a;i++)
        {
            for(int j=0;j<b;j++)
            {
                sum1[y++]=L[i]+M[j];
            }
        }
        sort(sum1,sum1+y);//用sort函数排序更方便,其头文件是#include<algorithm>
        int x;
        scanf("%d",&s);
        printf("Case %d:\n",d++);
        while(s--)
        {
            scanf("%d",&x);
            for(int i=0;i<c;i++)
            { 
                int i1=0,i2=y-1,mid;
                int m=x-N[i];//注意是N[i]不是M[i]
                while(i1<=i2)//这个二分法直接用模板就可以了
                {
                    mid=(i1+i2)/2;
                    if(m==sum1[mid])
                    {
                        printf("YES\n");
                        goto a;//注意跳出两轮循环
                    }
                    else if(sum1[mid]>m)
                    {
                        i2=mid-1;
                    }
                    else if(sum1[mid]<m)
                    {
                        i1=mid+1;
                    }
                }
               
            }
            printf("NO\n");//输出NO的条件是一个符合条件的i都不存在故应在for语句外
            a:;
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值