每日一题 Expedition

Expedition

Description

A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to run over a rock and puncture the truck’s fuel tank. The truck now leaks one unit of fuel every unit of distance it travels.

To repair the truck, the cows need to drive to the nearest town (no more than 1,000,000 units distant) down a long, winding road. On this road, between the town and the current location of the truck, there are N (1 <= N <= 10,000) fuel stops where the cows can stop to acquire additional fuel (1…100 units at each stop).

The jungle is a dangerous place for humans and is especially dangerous for cows. Therefore, the cows want to make the minimum possible number of stops for fuel on the way to the town. Fortunately, the capacity of the fuel tank on their truck is so large that there is effectively no limit to the amount of fuel it can hold. The truck is currently L units away from the town and has P units of fuel (1 <= P <= 1,000,000).

Determine the minimum number of stops needed to reach the town, or if the cows cannot reach the town at all.
Input

  • Line 1: A single integer, N

  • Lines 2…N+1: Each line contains two space-separated integers describing a fuel stop: The first integer is the distance from the town to the stop; the second is the amount of fuel available at that stop.

  • Line N+2: Two space-separated integers, L and P
    Output

  • Line 1: A single integer giving the minimum number of fuel stops necessary to reach the town. If it is not possible to reach the town, output -1.

Sample Input

4
4 4
5 2
11 5
15 10
25 10

Sample Output

2

Hint

INPUT DETAILS:

The truck is 25 units away from the town; the truck has 10 units of fuel. Along the road, there are 4 fuel stops at distances 4, 5, 11, and 15 from the town (so these are initially at distances 21, 20, 14, and 10 from the truck). These fuel stops can supply up to 4, 2, 5, and 10 units of fuel, respectively.

OUTPUT DETAILS:

Drive 10 units, stop to acquire 10 more units of fuel, drive 4 more units, stop to acquire 5 more units of fuel, then drive to the town.

分析:
为了使加油的次数尽可能的少,卡车应该在每次油用尽之前在可到达的加油站中选择一个加油站,使汽车能加最多的油,这样到达终点之时汽车加油的次数最少。
所以,在经过的点中选择一个最大的,可以想到用优先队列

  • 每经过一个加油站就将加油站加入到优先队列中(自动排序,默认从大到小)。
  • 在油用尽的时候从队列中选油最多的加油站加油(如果队列为空则不能到达终点)。并将该加油站出队。
#include<iostream>
#include<algorithm>
#include<queue>
#define x first
#define y second
using namespace std;
typedef pair<int, int> PII;
const int N = 10010;
int a[N], b[N];
PII pai[N];
int n, l, p;
void check()
{
	pai[n] = make_pair(l,0); //将终点看作距离起点为l可以加0的加油站,方便计算
	n++;
	sort(pai, pai + n);//排序,pair数组中的加油站为从起点到终点的顺序

	priority_queue<int> q;
	int ans = 0, pos = 0, u = p; //ans:加油次数   pos:现在所在的位置   u:卡车现有的油量

	for (int i = 0;i < n;i++)
	{
		int d = pai[i].x-pos; //距离下一个加油站得距离

		while (u < d) //油箱中的油不够到达下一个加油站
		{
			if (q.empty()) //队列中没有加油站能加油了
			{
				cout << -1 << endl;
				return;
			}

			u += q.top(); //加最多的油(优先队列默认是最大堆,所以队头元素是最大值)
			q.pop(); //加过油加油站的出队
			ans++;
		}
		q.push(pai[i].y); //可到达的加油站都入队(优先队列自动排序)
		u -= d;
		pos = pai[i].x;
	}
	cout << ans << endl;
}
int main()
{
	cin >> n;
	for (int i = 0;i < n;i++) cin >> a[i] >> b[i];
	cin >> l >> p;
	for (int i = 0;i < n;i++) pai[i] = make_pair(l - a[i],b[i]);
	//用pair类型存储加油站 距起点的距离 以及存有的油
	check();
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值