本题要求实现带头结点的链式表操作集。
函数接口定义:
List MakeEmpty();
Position Find( List L, ElementType X );
bool Insert( List L, ElementType X, Position P );
bool Delete( List L, Position P );
其中List结构定义如下:
typedef struct LNode *PtrToLNode;
struct LNode {
ElementType Data;
PtrToLNode Next;
};
typedef PtrToLNode Position;
typedef PtrToLNode List;
各个操作函数的定义为:
List MakeEmpty():创建并返回一个空的线性表;
Position Find( List L, ElementType X ):返回线性表中X的位置。若找不到则返回ERROR;
bool Insert( List L, ElementType X, Position P ):将X插入在位置P指向的结点之前,返回true。如果参数P指向非法位置,则打印“Wrong Position for Insertion”,返回false;
bool Delete( List L, Position P ):将位置P的元素删除并返回true。若参数P指向非法位置,则打印“Wrong Position for Deletion”并返回false。
裁判测试程序样例:
#include <stdio.h>
#include <stdlib.h>
#define ERROR NULL
typedef enum {false, true} bool;
typedef int ElementType;
typedef struct LNode *PtrToLNode;
struct LNode {
ElementType Data;
PtrToLNode Next;
};
typedef PtrToLNode Position;
typedef PtrToLNode List;
List MakeEmpty();
Position Find( List L, ElementType X );
bool Insert( List L, ElementType X, Position P );
bool Delete( List L, Position P );
int main()
{
List L;
ElementType X;
Position P;
int N;
bool flag;
L = MakeEmpty();
scanf("%d", &N);
while ( N-- ) {
scanf("%d", &X);
flag = Insert(L, X, L->Next);
if ( flag==false ) printf("Wrong Answer\n");
}
scanf("%d", &N);
while ( N-- ) {
scanf("%d", &X);
P = Find(L, X);
if ( P == ERROR )
printf("Finding Error: %d is not in.\n", X);
else {
flag = Delete(L, P);
printf("%d is found and deleted.\n", X);
if ( flag==false )
printf("Wrong Answer.\n");
}
}
flag = Insert(L, X, NULL);
if ( flag==false ) printf("Wrong Answer\n");
else
printf("%d is inserted as the last element.\n", X);
P = (Position)malloc(sizeof(struct LNode));
flag = Insert(L, X, P);
if ( flag==true ) printf("Wrong Answer\n");
flag = Delete(L, P);
if ( flag==true ) printf("Wrong Answer\n");
for ( P=L->Next; P; P = P->Next ) printf("%d ", P->Data);
return 0;
}
/* 你的代码将被嵌在这里 */
输入样例:
6
12 2 4 87 10 2
4
2 12 87 5
输出样例:
2 is found and deleted.
12 is found and deleted.
87 is found and deleted.
Finding Error: 5 is not in.
5 is inserted as the last element.
Wrong Position for Insertion
Wrong Position for Deletion
10 4 2 5
//:创建并返回一个空的线性表;
List MakeEmpty()
{
List a=(List)malloc(sizeof(struct LNode));
a->Data=0;
a->Next=NULL;
return a;//返回的是头结点
}
//:返回线性表中X的位置。若找不到则返回ERROR;
Position Find( List L, ElementType X )
{
List F=L;
while(F)
{
if(F->Data==X)
return F;
F=F->Next;
}
return ERROR;
}
//:将X插入在位置P指向的结点之前,返回true。如果参数P指向非法位置,则打印“Wrong Position for Insertion”,返回false;
bool Insert( List L, ElementType X, Position P )
{
List F=L;
while(F)//因为有头结点,所以不用考虑插入的结点变成第一个结点,只能在头结点后面
{
if(F->Next==P)//要知道P的前一个结点是什么
{
List n=(List)malloc(sizeof(struct LNode));
n->Data=X;
n->Next=P;
F->Next=n;
return true;
}
F=F->Next;
}
printf("Wrong Position for Insertion\n");
return false;
}
//:将位置P的元素删除并返回true。若参数P指向非法位置,则打印“Wrong Position for Deletion”并返回false。
bool Delete( List L, Position P )
{
List F=L;
if(!P)//P是NULL
{
printf("Wrong Position for Deletion\n");
return false;
}
while(F->Next)
{
if(F->Next==P)
{
F->Next=P->Next;//P的前一个结点的Next指向P的后一个结点
free(P);
return true;
}
F=F->Next;
}
printf("Wrong Position for Deletion\n");
return false;
}
完整代码
#include <stdio.h>
#include <stdlib.h>
#define ERROR NULL
typedef enum {false, true} bool;
typedef int ElementType;
typedef struct LNode *PtrToLNode;
struct LNode {
ElementType Data;
PtrToLNode Next;
};
typedef PtrToLNode Position;
typedef PtrToLNode List;
List MakeEmpty(void);//创建返回空表
Position Find( List L, ElementType X );//查找
bool Insert( List L, ElementType X, Position P );//添加
bool Delete( List L, Position P );//删除
bool F(List L);//释放
int main(void)
{
List L;
ElementType X;
Position P;
int N;
bool flag;
L = MakeEmpty();
scanf("%d", &N);
while ( N-- ) {
scanf("%d", &X);
flag = Insert(L, X, L->Next);
if ( flag==false ) printf("Wrong Answer\n");
}
scanf("%d", &N);
while ( N-- ) {
scanf("%d", &X);
P = Find(L, X);
if ( P == ERROR )
printf("Finding Error: %d is not in.\n", X);
else {
flag = Delete(L, P);
printf("%d is found and deleted.\n", X);
if ( flag==false )
printf("Wrong Answer.\n");
}
}
flag = Insert(L, X, NULL);
if ( flag==false ) printf("Wrong Answer\n");
else
printf("%d is inserted as the last element.\n", X);
P = (Position)malloc(sizeof(struct LNode));
flag = Insert(L, X, P);
if ( flag==true ) printf("Wrong Answer\n");
flag = Delete(L, P);
if ( flag==true ) printf("Wrong Answer\n");
for ( P=L->Next; P; P = P->Next ) printf("%d ", P->Data);
F(L);
return 0;
}
bool F(List L)
{
List p=L;
if(p==NULL)
return false;
while(p!=NULL)
{
L=p->Next;
free(p);
p=L;
}
return true;
}
//:创建并返回一个空的线性表;
List MakeEmpty(void)
{
List a=(List)malloc(sizeof(struct LNode));
a->Data=0;
a->Next=NULL;
return a;//返回的是头结点
}
//:返回线性表中X的位置。若找不到则返回ERROR;
Position Find( List L, ElementType X )
{
List F=L;
while(F)
{
if(F->Data==X)
return F;
F=F->Next;
}
return ERROR;
}
//:将X插入在位置P指向的结点之前,返回true。如果参数P指向非法位置,则打印“Wrong Position for Insertion”,返回false;
bool Insert( List L, ElementType X, Position P )
{
List F=L;
while(F)//因为有头结点,所以不用考虑插入的结点变成第一个结点,只能在头结点后面
{
if(F->Next==P)//要知道P的前一个结点是什么
{
List n=(List)malloc(sizeof(struct LNode));
n->Data=X;
n->Next=P;
F->Next=n;
return true;
}
F=F->Next;
}
printf("Wrong Position for Insertion\n");
return false;
}
//:将位置P的元素删除并返回true。若参数P指向非法位置,则打印“Wrong Position for Deletion”并返回false。
bool Delete( List L, Position P )
{
List F=L;
if(!P)//P是NULL
{
printf("Wrong Position for Deletion\n");
return false;
}
while(F->Next)
{
if(F->Next==P)
{
F->Next=P->Next;//P的前一个结点的Next指向P的后一个结点
free(P);
return true;
}
F=F->Next;
}
printf("Wrong Position for Deletion\n");
return false;
}