Problem Description
小明正在利用股票的波动程度来研究股票。
小明拿到了一只股票每天收盘时的价格,他想知道,这只股票连续几天的最大波动值是多少,即在这几天中某天收盘价格与前一天收盘价格之差的绝对值最大是多少。
Input Format
输入的第一行包含了一个整数 n,表示小明拿到的收盘价格的连续天数。
第二行包含 n 个正整数,依次表示每天的收盘价格。
Output Format
输出一个整数,表示这只股票这 n 天中的最大波动值。
Scope of Data
对于所有评测用例,2 ≤ n ≤ 1000。
股票每一天的价格为 1 到 10000 之间的整数。
Sample Input
Sample Output
Explain the Sample
第四天和第五天之间的波动最大,波动值为 |3−7| = 4。
Idea
I have no more to say.
Program Code
#include <iostream>
#include <cmath>
using namespace std;
const int N = 1010;
int n;
int stock[N];
int main()
{
int t, max_dif = -1;
cin >> n;
for(int i = 1; i <= n; ++ i)
{
cin >> stock[i];
if(i > 1)
{
t = abs(stock[i] - stock[i - 1]);
max_dif = t > max_dif ? t : max_dif;
}
}
cout << max_dif << endl;
return 0;
}
- If you have any questions,please feel free to communicate with me.