C++STL中next_permutation使用说明(全排列)

全排列:
描述

给定一个由不同的小写字母组成的字符串,输出这个字符串的所有全排列。 我们假设对于小写字母有'a' < 'b' < ... < 'y' < 'z',而且给定的字符串中的字母已经按照从小到大的顺序排列。 

输入
输入只有一行,是一个由不同的小写字母组成的字符串,已知字符串的长度在1到6之间。
输出
输出这个字符串的所有排列方式,每行一个排列。要求字母序比较小的排列在前面。字母序如下定义:

已知S = s1s2...sk , T = t1t2...tk,则S < T 等价于,存在p (1 <= p <= k),使得
s1 = t1, s2 = t2, ..., sp - 1 = tp - 1, sp < tp成立。
样例输入

abc

样例输出

abc
acb
bac
bca
cab
cba
   使用递归不能按小到大的要求输出
#include <iostream>
using namespace std;
void perm(char a[],int start,int end){
    if(start==end){
    for(int i=0;i<=end;i++){
        cout<<a[i];}
        cout<<endl;}
    else {
        for(int j=start;j<=end;j++){
            swap(a[start],a[j]);
            perm(a,start+1,end);
            swap(a[start],a[j]);}}
}
int main()
{
    char a[10];
    for(int k=0;k<3;k++){
        cin>>a[k];}
    perm(a,0,2);
    return 0;
}
/*
abc
abc
acb
bac
bca
cba
cab
*/

以上代码使用交换确定高位,在进行低位的交换,进行枚举,因此不会对顺序进行排序,而此题要求较小(ASCII码)的字母排在前面。
第一层:
a b c;初始
b a c;a与b交换
c b a;此时便出现问题,a应该在b之前 所以应该先输出c a b然后输出 c b a
而在next_permutation中,它先进行排序(默认升序),在进行查重
next_permutation
头文件:include <algorithm>
对于next_permutation函数,其函数原型为:

  #include <algorithm>

     bool next_permutation(iterator start,iterator end)

当前序列不存在下一个排列时,函数返回false,否则返回true

next_permutation(start,end)
next_permutation(start,end,cmp)//类似sort,它也可以自定义函数cmp,进行排序

next_permutation(start,end)函数是从start~end的n个元素进行全排列,
(1)排序(2)枚举查重

#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
char a[10];
int main()
{
    int n;
    while(cin>>a)
    {
        n=strlen(a);//计算数组a中的元素个数
        do
        {
           for(int i=0;i<n;i++)
           cout<<a[i];
           cout<<endl;
        }while(next_permutation(a,a+n));
    }
    return 0;
}
/*
abc
abc
acb
bac
bca
cab
cba
*/

next_permutation(start,end),和prev_permutation(start,end)。这两个函数作用是一样的,区别就在于前者求的是当前排列的下一个排列,后一个求的是当前排列的上一个排列。
prev_permutation(start,end)

#include <iostream>
#include <algorithm>
using namespace std;
int main()
{
    int num[3]={3,2,1};
    do
    {
        cout<<num[0]<<" "<<num[1]<<" "<<num[2]<<endl;
    }while(prev_permutation(num,num+3));
    return 0;
}
/*
3 2 1
3 1 2
2 3 1
2 1 3
1 3 2
1 2 3

Process returned 0 (0x0)   execution time : 0.033 s
Press any key to continue.
*/

next_permutation(start,end)

#include <iostream>
#include <algorithm>
using namespace std;
int main()
{
    int num[3]={3,2,1};
    do
    {
        cout<<num[0]<<" "<<num[1]<<" "<<num[2]<<endl;
    }while(next_permutation(num,num+3));
    return 0;
}
/*
3 2 1
Process returned 0 (0x0)   execution time : 0.028 s
Press any key to continue.
*/
#include <iostream>
#include <algorithm>
using namespace std;
int main()
{
    int num[3]={1,2,3};
    do
    {
        cout<<num[0]<<" "<<num[1]<<" "<<num[2]<<endl;
    }while(next_permutation(num,num+3));
    return 0;
}
/*
1 2 3
1 3 2
2 1 3
2 3 1
3 1 2
3 2 1
Process returned 0 (0x0)   execution time : 0.030 s
Press any key to continue.
*/
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值