PTA 自测-4 Have Fun with Numbers (20 分)

PTA自测 No 4

自测-4 Have Fun with Numbers (20 分)
Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:
Each input contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:
For each test case, first print in a line “Yes” if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or “No” if not. Then in the next line, print the doubled number.

Sample Input:
1234567899
Sample Output:
Yes
2469135798

代码:

/*思路:
使用sort对原字符组和double后的字符组进行比较,sort后会改变字符顺序所以使用k[21]复制double后的字符组*/
#include<bits/stdc++.h>
using namespace std;
int main(){
	char n[21],m[21],k[21];
	cin>>n;
	int l=strlen(n), num, i, flag=0;
  	for(i=l-1; i>=0; i--){
  		num=n[i]-'0';
  		num=num*2+flag;
  		flag=0;
  		if(num>=10){
  	    	num-=10;
  	    	flag=1;
	  	}
	  	m[i]=(num+'0');
  	}
  	strcpy(k,m);
  	if(flag==1)
		cout<<"No\n"<<"1"<<k;
	else{
		sort(n,n+l);sort(m,m+l);
		strcmp(n,m)==0?cout<<"Yes\n"<<k:cout<<"No\n"<<k;
	} 
	return 0;
} 
  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值