Bound Found

Bound Found
Signals of most probably extra-terrestrial origin have been received and digitalized by The Aeronautic and Space Administration (that must be going through a defiant phase: “But I want to use feet, not meters!”). Each signal seems to come in two parts: a sequence of n integer values and a non-negative integer t. We’ll not go into details, but researchers found out that a signal encodes two integer values. These can be found as the lower and upper bound of a subrange of the sequence whose absolute value of its sum is closest to t.

You are given the sequence of n integers and the non-negative target t. You are to find a non-empty range of the sequence (i.e. a continuous subsequence) and output its lower index l and its upper index u. The absolute value of the sum of the values of the sequence from the l-th to the u-th element (inclusive) must be at least as close to t as the absolute value of the sum of any other non-empty range.
Input
The input file contains several test cases. Each test case starts with two numbers n and k. Input is terminated by n=k=0. Otherwise, 1<=n<=100000 and there follow n integers with absolute values <=10000 which constitute the sequence. Then follow k queries for this sequence. Each query is a target t with 0<=t<=1000000000.
Output
For each query output 3 numbers on a line: some closest absolute sum and the lower and upper indices of some range where this absolute sum is achieved. Possible indices start with 1 and go up to n.
Sample Input
5 1
-10 -5 0 5 10
3
10 2
-9 8 -7 6 -5 4 -3 2 -1 0
5 11
15 2
-1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1
15 100
0 0
Sample Output
5 4 4
5 2 8
9 1 1
15 1 15
15 1 15


求一个数组中之和最接近t的的子数组的和的绝对值和左右端点。

#include <iostream>
#include <algorithm>
#include <cstring>

using namespace std;
typedef long long LL ;
const int N = 100005 ;
int maxn = 0x3f3f3f3f ;
struct node
{
    LL num ;
    LL sum ;
}a[N];

bool cmp(node x , node y){
    return x.sum < y.sum ;
}

int main()
{
    int n , k ;
    while(1)
    {
        cin >> n >> k ;
        if(n==0 && k==0)
            break ;
        memset(a , 0 , sizeof(a)) ;
        LL x ;
        for(int i = 1 ; i <= n ; i ++)
        {
            cin >> x ;
            a[i].sum = x + a[i-1].sum ;
            a[i].num = i ;
        }

        sort(a , a+n+1 , cmp) ;

        while(k--)
        {
            LL t ;
            cin >> t ;
            int l = 0 , r = 1 , ll , rr ;
            LL ans = 0 , he = 0 ;
            maxn = 0x3f3f3f3f ;
            while(r <= n)
            {
                ans = a[r].sum - a[l].sum ;
                if( abs(ans-t) < maxn ) //区间和最接近于t
                {
                    maxn = abs(ans-t) ;
                    ll = a[l].num ;
                    rr = a[r].num ;
                    he = abs(ans) ;
                }
                if(ans == t)
                    break ;
                else if(ans < t)
                    r ++ ;
                else
                    l ++ ;
                if(l == r)
                    r ++ ;
            }
            if(ll > rr)
                swap(ll , rr) ;
            cout << he << ' ' << ll+1 << ' ' << rr << endl ;
        }
    }
    return 0 ;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值