小希的迷宫 HDU - 1272 + Is It A Tree? POJ - 1308 (并查集)

小希的迷宫

上次Gardon的迷宫城堡小希玩了很久(见Problem B),现在她也想设计一个迷宫让Gardon来走。但是她设计迷宫的思路不一样,首先她认为所有的通道都应该是双向连通的,就是说如果有一个通道连通了房间A和B,那么既可以通过它从房间A走到房间B,也可以通过它从房间B走到房间A,为了提高难度,小希希望任意两个房间有且仅有一条路径可以相通(除非走了回头路)。小希现在把她的设计图给你,让你帮忙判断她的设计图是否符合她的设计思路。比如下面的例子,前两个是符合条件的,但是最后一个却有两种方法从5到达8。

在这里插入图片描述
Input
输入包含多组数据,每组数据是一个以0 0结尾的整数对列表,表示了一条通道连接的两个房间的编号。房间的编号至少为1,且不超过100000。每两组数据之间有一个空行。
整个文件以两个-1结尾。
Output
对于输入的每一组数据,输出仅包括一行。如果该迷宫符合小希的思路,那么输出"Yes",否则输出"No"。
Sample Input

6 8  5 3  5 2  6 4
5 6  0 0

8 1  7 3  6 2  8 9  7 5
7 4  7 8  7 6  0 0

3 8  6 8  6 4
5 3  5 6  5 2  0 0

-1 -1

Sample Output

Yes
Yes
No

题意: 输入多个点的信息,输入结束后判读是否是一棵树。

思路: 并查集。多个点只能有一个祖先,并且从一个点到另一个点只能有一条唯一路径,在实现的时候对输入的a,b(输入a和b就表示a和b直接是连接的),在a和b祖先不同时进行一个合并,使他们有相同祖先。然后接着输入,在每一次输入之后都要进行一个if (find(a) == find(b))的判断,如果相等说明之前从a到b已经有一条路径了,这个已经是第二条了,所以不能满足条件。在满足第三个条件,当有孤立的点的时候,也就是自己为自己的祖先的时候,是不成立的。

代码:

#include<iostream>
#include<cstdio>

using namespace std;

const int N = 100010;
int p[N];

int find(int x)
{
    if(p[x]!=x) p[x]=find(p[x]);
    return p[x];
}

int main()
{
    while(true)
    {
        int a,b;
        bool cnt=false;

        memset(p,0,sizeof(p));

        while(~scanf("%d %d",&a,&b))
        {
            if(a==-1&&b==-1) return 0;
            if(a==0&&b==0) break;

            if(p[a]==0) p[a]=a;
            if(p[b]==0) p[b]=b;

            int px=find(a), py=find(b);

            if(px!=py) p[px]=py;
            else cnt=true;
        }
        int ans=0;
        for(int i=1;i<=N;i++)
        {
            if(p[i]==i) ans++;
        }
        if(ans>1) cnt=true;
        if(cnt) printf("No\n");
        else printf("Yes\n");
    }

    return 0;
}

原题链接:
vjudge
hdu


Is It A Tree?

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties.

There is exactly one node, called the root, to which no directed edges point.
Every node except the root has exactly one edge pointing to it.
There is a unique sequence of directed edges from the root to each node.
For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.

在这里插入图片描述

Input
The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.
Output
For each test case display the line “Case k is a tree.” or the line “Case k is not a tree.”, where k corresponds to the test case number (they are sequentially numbered starting with 1).
Sample Input

6 8  5 3  5 2  6 4
5 6  0 0

8 1  7 3  6 2  8 9  7 5
7 4  7 8  7 6  0 0

3 8  6 8  6 4
5 3  5 6  5 2  0 0
-1 -1

Sample Output

Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.

这题的题意和思路与小希的迷宫一模一样就是最后输出的语句不同。

代码:

#include<iostream>
#include<cstdio>

using namespace std;

const int N = 100010;
int p[N];

int find(int x)
{
    if(p[x]!=x) p[x]=find(p[x]);
    return p[x];
}

int main()
{
    int res=1;
    while(true)
    {
        int a,b;
        bool cnt=false;

        memset(p,0,sizeof(p));

        while(~scanf("%d %d",&a,&b))
        {
            if(a==-1&&b==-1) return 0;
            if(a==0&&b==0) break;

            if(p[a]==0) p[a]=a;
            if(p[b]==0) p[b]=b;

            int px=find(a), py=find(b);

            if(px!=py) p[px]=py;
            else cnt=true;
        }
        int ans=0;
        for(int i=1;i<=N;i++)
        {
            if(p[i]==i) ans++;
        }
        if(ans>1) cnt=true;
        if(cnt) printf("Case %d is not a tree.\n",res++);
        else printf("Case %d is a tree.\n",res++);
    }

    return 0;
}

原题链接:
judge
poj

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值