Expedition

Expedition

Description

A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to run over a rock and puncture the truck’s fuel tank. The truck now leaks one unit of fuel every unit of distance it travels.

To repair the truck, the cows need to drive to the nearest town (no more than 1,000,000 units distant) down a long, winding road. On this road, between the town and the current location of the truck, there are N (1 <= N <= 10,000) fuel stops where the cows can stop to acquire additional fuel (1…100 units at each stop).

The jungle is a dangerous place for humans and is especially dangerous for cows. Therefore, the cows want to make the minimum possible number of stops for fuel on the way to the town. Fortunately, the capacity of the fuel tank on their truck is so large that there is effectively no limit to the amount of fuel it can hold. The truck is currently L units away from the town and has P units of fuel (1 <= P <= 1,000,000).

Determine the minimum number of stops needed to reach the town, or if the cows cannot reach the town at all.

Input

  • Line 1: A single integer, N

  • Lines 2…N+1: Each line contains two space-separated integers describing a fuel stop: The first integer is the distance from the town to the stop; the second is the amount of fuel available at that stop.

  • Line N+2: Two space-separated integers, L and P

Output

  • Line 1: A single integer giving the minimum number of fuel stops necessary to reach the town. If it is not possible to reach the town, output -1.
    Sample Input

Sample Input

4
4 4
5 2
11 5
15 10
25 10

Sample Output

2

注:用G++提交可以通过

代码如下:

#include<iostream>
#include<algorithm>
#include<queue>
#include<vector>
#include<string>
#include<utility>
using namespace std;

typedef pair<int,int> PII;
const int N=10010;
int n,L,P,A[N],B[N],ans;
vector<PII>v;
priority_queue<PII>q;

int main(){
    cin>>n;
    for(int i=0;i<n;i++) {
        cin>>A[i]>>B[i];
        v.push_back({A[i],B[i]});
    }
    A[n]=0,B[n]=0,n++;
    v.push_back({A[n],B[n]});
    cin>>L>>P;
    sort(v.begin(),v.end());
    reverse(v.begin(),v.end());
    
    for(int i=0;i<n;i++){
        int d=L-v[i].first;
        while(d>P){
            if(q.empty()){
                cout<<"-1";
                return 0;
            }
            P+=q.top().first;
            q.pop(); 
            ans++;
        }
        P-=d;
        L=v[i].first;
        q.push({v[i].second,v[i].first});
    }
    cout<<ans;
    return 0;
}

原题链接:
http://poj.org/problem?id=2431
https://ac.nowcoder.com/acm/problem/107028

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值