线性动态规划B

B
Today is army day, but the servicemen are busy with the phalanx for the celebration of the 60th anniversary of the PRC.
A phalanx is a matrix of size nn, each element is a character (a~z or A~Z), standing for the military branch of the servicemen on that position.
For some special requirement it has to find out the size of the max symmetrical sub-array. And with no doubt, the Central Military Committee gave this task to ALPCs.
A symmetrical matrix is such a matrix that it is symmetrical by the “left-down to right-up” line. The element on the corresponding place should be the same. For example, here is a 3
3 symmetrical matrix:
cbx
cpb
zcc
Input
There are several test cases in the input file. Each case starts with an integer n (0<n<=1000), followed by n lines which has n character. There won’t be any blank spaces between characters or the end of line. The input file is ended with a 0.
Output
Each test case output one line, the size of the maximum symmetrical sub- matrix.
Sample Input
3
abx
cyb
zca
4
zaba
cbab
abbc
cacq
0
Sample Output
3
3
题目问在一个n*n的矩阵中,寻找一个最大的子矩阵,使它沿右上到坐下对角线对称。
在这里插入图片描述
题解:沿对角线设关于该点可以形成当前最大子矩阵dp[i][j],则沿对角线继续向下去寻找符合题目所给要求的对称关系,如果有则该点dp++,继续在该点上寻找扩大后的矩阵,如果没有则继续向下寻找。
完整代码

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<math.h>
#include<iostream>
#include<algorithm>
#include<queue>
#include<map>
#include<cstdio>
#include<vector>
#include<set>
#include<cstring>
#include<cstdlib>
#include<time.h>
#include<stack>
using namespace std;
#define maxn 1005
int main()
{
	int n;
	int dp[maxn][maxn];
	char a[maxn][maxn];
	while(scanf("%d",&n)!=EOF){
		if(n==0)break;
		for(int i=0;i<n;i++)
			scanf("%s",a[i]);
		memset(dp,0,sizeof(dp));
		int ans=1;	
		for(int i=0;i<n;i++){
			for(int j=n-1;j>=0;j--){
				dp[i][j] = 1;
				if( i == 0 || j == n-1) continue;
				int t = dp[i-1][j+1];
				for(int k=1;k<=t;k++)
				{
					if(a[i-k][j] == a[i][k+j] ) dp[i][j]++;
					else break;
				}
				ans = max(dp[i][j],ans);
		}
	}
	cout<<ans<<endl;
	}	
  return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值