Phalanx HDU2859(dp)

Phalanx

Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4581 Accepted Submission(s): 2144

Problem Description
Today is army day, but the servicemen are busy with the phalanx for the celebration of the 60th anniversary of the PRC.
A phalanx is a matrix of size nn, each element is a character (a~z or A~Z), standing for the military branch of the servicemen on that position.
For some special requirement it has to find out the size of the max symmetrical sub-array. And with no doubt, the Central Military Committee gave this task to ALPCs.
A symmetrical matrix is such a matrix that it is symmetrical by the “left-down to right-up” line. The element on the corresponding place should be the same. For example, here is a 3
3 symmetrical matrix:
cbx
cpb
zcc

Input
There are several test cases in the input file. Each case starts with an integer n (0<n<=1000), followed by n lines which has n character. There won’t be any blank spaces between characters or the end of line. The input file is ended with a 0.

Output
Each test case output one line, the size of the maximum symmetrical sub- matrix.

解释

想到以dp[i][j]作为以(i, j)为子矩阵左下角的最大子矩阵边长大小。
转移方程为 dp[i][j] = min(cont, dp[i-1][j+1])+1;
cont 为从(i,j)往i-1和j+1两个方向走路过有多少组元素是匹配的(不包括(i,j)本身这一点。
新的最大子矩阵的边长取决于以(i-1,j+1)为矩阵左下角的最大边长和cont中小的那个。
ans选取dp中最大的结果, 注意当规模为1时ans没有更新,所以ans初值赋值为1。
如果空间限制再小,dp数组可以滚动为一维数组。

Sample Input
3
abx
cyb
zca
4
zaba
cbab
abbc
cacq
0

Sample Output
3
3

#include <cstdio>
#include <cstring>
#include <algorithm>
int const maxn = 1e3+2;
using namespace std;
int dp[maxn][maxn];
int maze[maxn][maxn];

int main(){
	int n, i, j;
	int ans, temp;
	int cont, x, y;
	while(~scanf("%d", &n) && n){
		for (i = 0; i < n; i++){
			getchar();
			for (j = 0; j < n; j++)
				scanf("%c", &maze[i][j]);
		}
		ans = 1;
		memset(dp, 0, sizeof(dp));
		for (i = 0; i < n; i++){
			for (j = 0; j < n; j++){
				if (i == 0 || j == n-1)
					dp[i][j] = 1;
				else{
					cont = 0;
					x = i-1; y = j+1;
					while(x >= 0 && y < n && maze[i][y] == maze[x][j]){
						cont++;
						x--;
						y++;
					}
					dp[i][j] = min(cont, dp[i-1][j+1]) + 1;
					ans = max(dp[i][j], ans);
				}
			}
		}
		printf("%d\n", ans);
	}	
	return 0;
} 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值