Anniversary party HDU-1520员工聚会 树形DP(链试前向星法) 寒假集训

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests’ conviviality ratings.
Input
Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go T lines that describe a supervisor relation tree. Each line of the tree specification has the form:
L K
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line
0 0
Output
Output should contain the maximal sum of guests’ ratings.
Sample Input
7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0
Sample Output
5
这道题有点坑,在poj上可以过的相同代码,到HDU就错了。
坑点在输入时的n是多组输入的,并且在输入上司的时候也是多组输入0 0 结束
解法有好多,我用的链试前向星存图,DFS跑图来做。把上司和员工连成一颗有根树,并从最大的上司开始跑,每次DP去找最大的数值和。DP方式比较简单,每个人只有两种状态,如果有父亲节点就没有儿子节点,所以有
状态转移方程:dp[x][0]+=max(dp[y][0],dp[y][1]); dp[x][1]+=dp[y][0];
最后记得每次将前向星置空

#include <stdio.h>
#include <string.h>
#include <math.h>
#include <map>
#include <stack>
#include <set>
#include <queue>
#include <vector>
#include <iostream>
#include <algorithm>
#include <cstring>
#include <string>
#include <cstdio>
#define ls (p<<1)
#define rs (p<<1|1)
//#include<bits/stdc++.h>
using namespace std;
const int maxn=10000;
bool father[maxn];
int dp[maxn][2],a[maxn];
struct edge{
    int ver,nex;
}e[maxn];
int head[maxn],tot;
void addedge(int u,int v){
    e[++tot].ver=v;
    e[tot].nex=head[u];
    head[u]=tot;
}
void dfs(int x){
    dp[x][0]=0;
    dp[x][1]=a[x];
    int y;
    for(int i=head[x];i!=-1;i=e[i].nex){
        y=e[i].ver;
        dfs(y);
        dp[x][0]+=max(dp[y][0],dp[y][1]);
        dp[x][1]+=dp[y][0];
    }
}
void solve(){
    int n;
    while(scanf("%d",&n)!=EOF){
    tot=0;
    memset(dp,0,sizeof(dp));
    memset(head,-1,sizeof(head));
    for(int i=1;i<=n;i++){
        scanf("%d",&a[i]);
    }
    int x,y;
    while(scanf("%d %d",&x,&y)!=EOF){
        if(x==0&&y==0)break;
        father[x]=1;
        addedge(y,x);
    }
    int root;
    for(int i=1;i<=n;i++){
        if(!father[i]){
            root=i;
            break;
        }
    }
        dfs(root);
        cout<<max(dp[root][0],dp[root][1])<<endl;
    }
}
int main()
{
    ios::sync_with_stdio(false),cin.tie(0),cout.tie(0);
    solve();
    //system("pause");
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值