There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.
Input
Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go N – 1 lines that describe a supervisor relation tree. Each line of the tree specification has the form:
L K
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line
0 0
Output
Output should contain the maximal sum of guests' ratings.
Sample Input
7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0
Sample Output
5
题解:输入n,接下来n行表示n个人的欢乐值,再接下来n行给出l,k(l的上司是k)要求找出一些人无直接上司下属关系并且欢乐值最高。
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int n,dp[6666][2],book[6666];
int a[6666],f[6666];
void dfs(int m)
{
book[m]=1;
for(int i=1; i<=n; i++)
if(book[i]==0&&f[i]==m)
{
dfs(i);
dp[m][1]+=dp[i][0];
dp[m][0]+=max(dp[i][0],dp[i][1]);
}
}
int main()
{
while(~scanf("%d",&n))
{
int i,j,l,k;
memset(dp,0,sizeof(dp));
memset(book,0,sizeof(book));
memset(a,0,sizeof(a));
for(i=1; i<=n; i++)
scanf("%d",&dp[i][1]);
while(~scanf("%d%d",&l,&k)&&(l||k))
{
f[l]=k;
a[l]=1;
}
int m;
for(i=1; i<=n; i++)
if(a[i]==0)
m=i;
dfs(m);
printf("%d\n",max(dp[m][0],dp[m][1]));
}
return 0;
}