链接
Bill is developing a new mathematical theory for human emotions. His recent investigations are dedicated
to studying how good or bad days influent people’s memories about some period of life.
A new idea Bill has recently developed assigns a non-negative integer value to each day of human
life. Bill calls this value the emotional value of the day. The greater the emotional value is, the better
the day was. Bill suggests that the value of some period of human life is proportional to the sum of the
emotional values of the days in the given period, multiplied by the smallest emotional value of the day
in it. This schema reflects that good on average period can be greatly spoiled by one very bad day.
Now Bill is planning to investigate his own life and find the period of his life that had the greatest
value. Help him to do so.
Input
The input will contain several test cases, each of them as described below. Consecutive test cases are
separated by a single blank line.
The first line of the input file contains n — the number of days of Bill’s life he is planning to
investigate (1 ≤ n ≤ 100000). The rest of the file contains n integer numbers a1, a2, . . . , an ranging
from 0 to 106 — the emotional values of the days. Numbers are separated by spaces and/or line breaks.
Output
For each test case, the output must follow the description below. The outputs of two consecutive cases
will be separated by a blank line.
On the first line of the output file print the greatest value of some period of Bill’s life.
On the second line print two numbers l and r such that the period from l-th to r-th day of Bill’s
life (inclusive) has the greatest possible value. If there are multiple periods with the greatest possible
value, then print any one of them.
Sample Input
6
3 1 6 4 5 2
Sample Output
60
3 5
分析:
对于一个长度为 n的数列,找出一个子区间,使子区间内的最小值与子区间长度的乘积最大,要求在满足舒适值最大的情况下最小化长度,最小化长度的情况下最小化左端点序号。
假设每个位置的值就是所在的区间的最小值,然后扩展左右边界,扩展的条件是待扩展的位置的值大于等于这个位置
当所有的值都为0时,输出应为 0 1 1
计算时用到了前缀和
这题要特别注意输出的格式
#include<bits/stdc++.h>
#define ll long long
using namespace std;
typedef unsigned long long ull;
const int N = 1e5+10,M = 1e6+10,P = 131;
ll l[N],r[N],a[N],h[N];
int main()
{
int n;
int f=0;
while(scanf("%d",&n)!=EOF)
{
if(f) printf("\n");
else f=1;
for(int i=1;i<=n;i++)
{
scanf("%lld",&a[i]);
l[i]=r[i]=i;
h[i]=h[i-1]+a[i];
}
for(int i=1;i<=n;i++)
while(l[i]>1&&a[i]<=a[l[i]-1]) l[i]=l[l[i]-1];
for(int i=n;i>=1;i--)
while(r[i]<n&&a[i]<=a[r[i]+1]) r[i]=r[r[i]+1];
ll ans=0,s;
int le=1,re=1;
for(int i=1;i<=n;i++)
{
s=(h[r[i]]-h[l[i]-1])*a[i];
if(ans<s)
{
ans=s;
le=l[i],re=r[i];
}
else if(ans==s)
{
if(re-le>r[i]-l[i])
{
le=l[i],re=r[i];
}
}
}
printf("%lld\n",ans);
printf("%d %d\n",le,re);
}
return 0;
}