PTA-1118 Birds in Forest(并查集)

这是一篇关于使用并查集算法解决计算机科学问题的文章。题目描述了一组科学家在森林中拍摄了数千只鸟,并要求计算最大可能的树木数量以及判断任意两只鸟是否在同一棵树上。解决方案通过初始化并查集,合并鸟所在的树,并用哈希表记录每棵树的鸟的数量。最后输出结果,包括最大树的数量、鸟的总数以及对查询的响应。
摘要由CSDN通过智能技术生成

PTA-1118 Birds in Forest

Some scientists took pictures of thousands of birds in a forest. Assume that all the birds appear in the same picture belong to the same tree. You are supposed to help the scientists to count the maximum number of trees in the forest, and for any pair of birds, tell if they are on the same tree.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (≤1e4) which is the number of pictures. Then N lines follow, each describes a picture in the format:KB1B2… BKwhere K is the number of birds in this picture, and Bi’s are the indices of birds. It is guaranteed that the birds in all the pictures are numbered continuously from 1 to some number that is no more than 104.After the pictures there is a positive number Q (≤1e4) which is the number of queries. Then Q lines follow, each contains the indices of two birds.

Output Specification:

For each test case, first output in a line the maximum possible number of trees and the number of birds. Then for each query, print in a line Yes if the two birds belong to the same tree, or No if not.

Sample Input:

4
3 10 1 2
2 3 4
4 1 5 7 8
3 9 6 4
2
10 5
3 7

Sample Output:

2 10
Yes
No

思路

这是一道基础的并查集题目,细节在于对于大量数据的处理,在合并操作后,因为小鸟的编号是从1开始连续的,所以我们从1开始遍历利用哈希表将每棵树的根结点作为key存储每棵树上鸟的数量,之后我们只需要利用哈希表的size得到不同树的数量。

解决代码

#include<bits/stdc++.h>
using namespace std;
const int maxx=1e4+5;
int a[maxx];
int h[maxx];
void init(int n)
{
	for(int i=1;i<=n;i++)
	{
		a[i]=i;
		h[i]=0;
	}
}
int find(int x)
{
	return x==a[x]? x: a[x]=find(a[x]);
}
void unite(int x,int y)
{
	x=find(x);
	y=find(y);
	if(x==y) return ;
	if(h[x]<h[y]) a[x]=y;
	else
	{
		a[y]=x;
		if(h[x]==h[y]) h[x]++;
	}
}
bool same(int x,int y)
{
	return find(x)==find(y);
}
int main()
{
	int n;
	cin>>n;
	init(10000);
	int top=0;
	unordered_map<int ,int> e;
	while(n--)
	{
		int x;
		cin>>x;
        int m[x];
		for(int i=0;i<x;i++)
		{
			cin>>m[i];
			if(m[i]>top) top=m[i];
		}
		for(int i=1;i<x;i++)
		{
			//cout<<"合并"<<m[0]<<' '<<m[i]<<endl;
			unite(m[0],m[i]);
		}
	}
	for(int i=1;i<=top;i++)
	{
		e[find(i)]++;
	}
	int size=e.size();
	cout<<size<<' '<<top<<endl;
	int w;
	cin>>w;
	while(w--)
	{
		int x,y;
		cin>>x>>y;
		if(same(x,y)) printf("Yes\n");
		else printf("No\n");
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

新西兰做的饭

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值