短学期实践计划//杭电OJ(1009)

FatMouse’ Trade
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 119147 Accepted Submission(s): 41165
Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]
a% pounds of JavaBeans if he pays F[i]
a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1’s. All integers are not greater than 1000.

Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

Sample Input
5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1

Sample Output
13.333
31.500**

思路:非常简单的贪心题型,优先选择性价比高的房间即可。
代码:

#include <iostream>
using namespace std;
#define MAXMUM 1005
int J[MAXMUM];
int F[MAXMUM];
double value[MAXMUM];
int main(){
    int M,N;
    while(cin>>M>>N&&M!=-1&&N!=-1){
        for(int i=0;i<N;i++){
            cin>>J[i]>>F[i];
            value[i] = 1.0*J[i]/F[i];
        }
        for(int i=0;i<N;i++){
            for(int j=i;j<N;j++){
                if(value[i]<value[j]){
                    swap(value[i],value[j]);
                    swap(J[i],J[j]);
                    swap(F[i],F[j]);
                }
            }
        }
        int now = 0;
        double num = 0;
        while(M&&now<N){
            if(M>=F[now]){
                M-=F[now];
                num+=J[now];
            }
            else{
                num+=M*value[now];
                M = 0;
            }
            now++;
        }
        printf("%.3f\n",num);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值