短学期实践计划//杭电OJ(1002)

**A + B Problem II
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 527153 Accepted Submission(s): 100781
Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input
2
1 2
112233445566778899 998877665544332211

Sample Output
Case 1:
1 + 2 = 3
Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110**

思路:最基础的大数运算题,使用C++类中编写大数类并进行运算符+的重载即可。
代码:

#include <iostream>
#include <string>
#include <cstring>
using namespace std;
class Integer{
    public:
        char num[1000];
        int size;
        Integer(int n = 0){
            memset(num,'0',1000);
            int i = 0;
            while(n){
                num[i] = n%10+'0';
                n/=10;
                i++;
            }
            size = i;
        }
        Integer(const string& str){
            memset(num,'0',1000);
            size = str.length();
            for(int i=0;i<size;i++)
                num[i] = str[size-i-1];
        }
        Integer operator+(const Integer& in){
            Integer n;
            n.size = size>in.size?size:in.size;
            for(int i=0;i<n.size;i++){
                n.num[i] = num[i]-'0'+in.num[i];
            }
            for(int i=0;i<n.size;i++){
                if(n.num[i]>'9'){
                    n.num[i]-=10;
                    n.num[i+1]++;
                }
            }
            if(n.num[n.size]>'0') n.size++;
            return n;
        }
        friend ostream& operator<<(ostream& ostr,const Integer& in){
            for(int i=in.size-1;i>=0;i--){
                ostr<<in.num[i];
            }
            return ostr;
        }
};
int main(){
    string A,B;
    int T;
    cin>>T;
    for(int i=1;i<=T;i++){
        cin>>A>>B;
        Integer A1(A),B1(B);
        cout<<"Case "<<i<<":"<<endl;
        cout<<A<<" + "<<B<<" = "<<A1+B1<<endl;
        if(T!=i) cout<<endl;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值