约瑟夫环问题sdut

Logout
约瑟夫问题
Time Limit: 1000 ms Memory Limit: 65536 KiB

Problem Description
n个人想玩残酷的死亡游戏,游戏规则如下:

n个人进行编号,分别从1到n,排成一个圈,顺时针从1开始数到m,数到m的人被杀,剩下的人继续游戏,活到最后的一个人是胜利者。

请输出最后一个人的编号。
Input
输入n和m值。
Output
输出胜利者的编号。
Sample Input
5 3
Sample Output
4
Hint
第一轮:3被杀第二轮:1被杀第三轮:5被杀第四轮:2被杀
Source
、、、、、、、、、、、、、、、、、、、、、、、、、、、、、、、、、
函数做法繁琐但容易理解
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
struct mon
{
int num;
struct mon *next;
};
struct mon *creat(int n)
{
int i;
struct mon *p,*tail,*head;
p=(struct mon *)malloc(sizeof(struct mon));
p->num=1;
p->next=NULL;
head=p;
tail=p;
for(i=2;i<=n;i++)
{
p=(struct mon *)malloc(sizeof(struct mon));
p->num=i;
tail->next=p;
tail=p;
p->next=NULL;
}
tail->next=head;
return head;
}
int sel( struct mon *head,int m,int n)
{
int num=0;
int count=0;
struct mon *p,*q;//p当前节点,q前驱节点
q=head;
while(q->next!=head)
q=q->next;//前驱节点移动到尾结点
//printf(“被删除人序号”)
while(count<n-1)
{
p=q->next;
num++;
if(num%m==0)
{
q->next=p->next;//删除
//printf(被删除的人
free§;
count++;

    }
    else q=p;
}
return q->num;//最后一个结点剩余

}
int main()
{
int n,m;
struct mon *head;
scanf("%d%d",&n,&m);
head=creat(n);
printf("%d",sel(head,m,n));
return 0;
}

第二种方法

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
struct node
{
int num;
struct node *next;

};
int main()
{
int n,m,i;
struct node *head,*p,q,tail;
head=(struct node
)malloc(sizeof(struct node));
head->next=NULL;
tail=head;
scanf("%d%d",&n,&m);
for(i=1;i<=n;i++)
{
p=(struct node
)malloc(sizeof(struct node));
p->num=i;
p->next=tail->next;
tail->next=p;
tail=p;
}
tail->next=head->next;
i=1;
q=head;
p=head->next;
while(1)//无限循环直至结果
{
if(q=p)//q==
break;
if(i==m)
{
tail=p;
q->next=tail->next;
i=1;
p=p->next;
free(tail);
}
else
{
q=p;
p=p->next;
i++;
}
}
printf("%d\n",p->num);
return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值