Function Run Fun-dp

Description
We all love recursion! Don’t we?
Consider a three-parameter recursive function w(a, b, c):
if a <= 0 or b <= 0 or c <= 0, then w(a, b, c) returns: 1
if a > 20 or b > 20 or c > 20, then w(a, b, c) returns: w(20, 20, 20)
if a < b and b < c, then w(a, b, c) returns: w(a, b, c-1) + w(a, b-1, c-1) - w(a, b-1, c)
otherwise it returns:
w(a-1, b, c) + w(a-1, b-1, c) + w(a-1, b, c-1) - w(a-1, b-1, c-1)
This is an easy function to implement. The problem is, if implemented directly, for moderate values of a, b and c (for example, a = 15, b = 15, c = 15), the program takes hours to run because of the massive recursion.
Input
The input for your program will be a series of integer triples, one per line, until the end-of-file flag of -1 -1 -1. Using the above technique, you are to calculate w(a, b, c) efficiently and print the result.
Output
Print the value for w(a,b,c) for each triple.
Sample Input
1 1 1
2 2 2
10 4 6
50 50 50
-1 7 18
-1 -1 -1
Sample Output
w(1, 1, 1) = 2
w(2, 2, 2) = 4
w(10, 4, 6) = 523
w(50, 50, 50) = 1048576
w(-1, 7, 18) = 1
//递归要避免重复计算

#include <bits/stdc++.h>
using namespace std;
long long dp[21][21][21];
long long f(int x,int y,int z)
{
    if(x<=0||y<=0||z<=0)
        return 1;
    if(x>20||y>20||z>20)
        return f(20,20,20);
    if(x<y&&y<z)
    {
        if(dp[x][y][z]==-1)
            dp[x][y][z]=f(x,y,z-1)+f(x,y-1,z-1)-f(x,y-1,z);
        return dp[x][y][z];
    }
    else 
    {
        if(dp[x][y][z]==-1)
            dp[x][y][z]=f(x-1,y,z)+f(x-1,y-1,z)+f(x-1,y,z-1)-f(x-1,y-1,z-1);
        return dp[x][y][z];
    }
}
int main()
{
    int x,y,z;
    while(cin>>x>>y>>z)
    {
        if(x==-1&&y==-1&&z==-1)
            break;
        memset(dp,-1,sizeof(dp));
        cout<<"w("<<x<<", "<<y<<", "<<z<<") = "<<f(x,y,z)<<endl;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值