POJ 1579

水题!

Description
We all love recursion! Don’t we?

Consider a three-parameter recursive function w(a, b, c):

if a <= 0 or b <= 0 or c <= 0, then w(a, b, c) returns:
1

if a > 20 or b > 20 or c > 20, then w(a, b, c) returns:
w(20, 20, 20)

if a < b and b < c, then w(a, b, c) returns:
w(a, b, c-1) + w(a, b-1, c-1) - w(a, b-1, c)

otherwise it returns:
w(a-1, b, c) + w(a-1, b-1, c) + w(a-1, b, c-1) - w(a-1, b-1, c-1)

This is an easy function to implement. The problem is, if implemented directly, for moderate values of a, b and c (for example, a = 15, b = 15, c = 15), the program takes hours to run because of the massive recursion.

Input
The input for your program will be a series of integer triples, one per line, until the end-of-file flag of -1 -1 -1. Using the above technique, you are to calculate w(a, b, c) efficiently and print the result.

Output
Print the value for w(a,b,c) for each triple.

Sample Input

1 1 1
2 2 2
10 4 6
50 50 50
-1 7 18
-1 -1 -1

Sample Output

w(1, 1, 1) = 2
w(2, 2, 2) = 4
w(10, 4, 6) = 523
w(50, 50, 50) = 1048576
w(-1, 7, 18) = 1

题意:
题意什么的,相信你能看懂,已经把函数都写好了,只是要注意的是为了避免重复的调用 ,所以采用记忆化搜索*


import java.util.Scanner;

public class Main{
    private static int x,y,z;
    private static int[][][] dp = new int[100][100][100];
    public static void main(String[] args) {
    Scanner scanner = new Scanner(System.in);
    while (scanner.hasNext()) {
        x = scanner.nextInt();
        y = scanner.nextInt();
        z = scanner.nextInt();
        if (x==-1&&y==-1&&z==-1) 
        break;
        int current = dfs(x, y, z);
        System.out.printf("w(%d, %d, %d) = %d\n",x,y,z,current);
    }
    scanner.close();
    }
    private static int dfs (int a,int b,int c )
    {
    if (a<=0||b<=0||c<=0) 
        return 1;
    if (a>20||b>20||c>20) 
        return dfs(20, 20, 20);
    if (dp[a][b][c]!=0)
        return dp[a][b][c];
    if (a<b&&b<c) 
    dp[a][b][c]=dfs(a, b, c-1)+dfs(a, b-1, c-1)-dfs(a, b-1, c);

    return dp[a][b][c]=dfs(a-1, b, c)+dfs(a-1, b-1, c)+dfs(a-1, b, c-1)-dfs(a-1, b-1, c-1);
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值