继续畅通工程
from hdu 1879
Time limit:1s
Memory limit:32MB
Problem Description
省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可)。现得到城镇道路统计表,表中列出了任意两城镇间修建道路的费用,以及该道路是否已经修通的状态。现请你编写程序,计算出全省畅通需要的最低成本。
Input
测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N ( 1< N < 100 );随后的 N(N-1)/2 行对应村庄间道路的成本及修建状态,每行给4个正整数,分别是两个村庄的编号(从1编号到N),此两村庄间道路的成本,以及修建状态:1表示已建,0表示未建。
当N为0时输入结束。
Output
每个测试用例的输出占一行,输出全省畅通需要的最低成本。
Sample Input
3
1 2 1 0
1 3 2 0
2 3 4 0
3
1 2 1 0
1 3 2 0
2 3 4 1
3
1 2 1 0
1 3 2 1
2 3 4 1
0
Sample Output
3
1
0
这个题目,最小生成树应用,一棵树,需要有合理的n-1条边将n个集合合并成为一个,我们将标号的1的(已经建好的路)两端的城市直接合并,对未建好的路费用从小到大遍历,如果两端的城市所属不同集合,则合并。
在合并的时候将需要的边(后面用need表示)减去1就可以了。
#include<cstdio>
#include<algorithm>
#include<vector>
using namespace std;
int father[105];
int find(int x){
if(father[x] == x)
return x;
return father[x] = find(father[x]);
}
struct E{
int f,t,w;
}e;
bool cmp(E a,E b){
return a.w < b.w;
}
int n,m,x,y,need,sum; //城市,边数,xy记录父亲查询,需要的边数,最小的费用
int main(){
while(scanf("%d",&n) && n){
vector<E> v;
for(int i = 1;i <= n;++i) father[i] = i;need = n - 1,sum = 0,m = n * (n - 1) / 2;
for(int i = 1;i <= m;++i){
scanf("%d %d %d %d",&e.f,&e.t,&e.w,&x);
if(!x) //如果是0,说明没建好,放入vector
v.push_back(e);
else{ //如果是1,则直接合并
x = find(e.f),y = find(e.t);
if(x != y)
father[x] = y,--need;
}
}
sort(v.begin(),v.end(),cmp);
for(int i = 0,j = v.size();need && i < j;++i){ //从小到大挑选需要的边
x = find(v[i].f),y = find(v[i].t);
if(x != y)
father[x] = y,--need,sum += v[i].w;
}
printf("%d\n",sum);
}
return 0;
}