Puzzle UVA - 227 PE代码求大佬指点

​   A children’s puzzle that was popular 30 years ago consisted of a 5×5 frame which contained 24 small squares of equal size. A unique letter of the alphabet was printed on each small square. Since there were only 24 squares within the frame, the frame also contained an empty position which was the same size as a small square. A square could be moved into that empty position if it were immediately to the right, to the left, above, or below the empty position. The object of the puzzle was to slide squares into the empty position so that the frame displayed the letters in alphabetical order.

​   The illustration below represents a puzzle in its original configuration and in its configuration after the following sequence of 6 moves:

  1. The square above the empty position moves.

  2. The square to the right of the empty position moves.

  3. The square to the right of the empty position moves.

  4. The square below the empty position moves.

  5. The square below the empty position moves.

  6. The square to the left of the empty position moves.

​   Write a program to display resulting frames given their initial configurations and sequences of moves

Input

​   Input for your program consists of several puzzles. Each is described by its initial configuration and the sequence of moves on the puzzle. The first 5 lines of each puzzle description are the starting configuration. Subsequent lines give the sequence of moves.

​   The first line of the frame display corresponds to the top line of squares in the puzzle. The other lines follow in order. The empty position in a frame is indicated by a blank. Each display line contains exactly 5 characters, beginning with the character on the leftmost square (or a blank if the leftmost square is actually the empty frame position). The display lines will correspond to a legitimate puzzle.

​   The sequence of moves is represented by a sequence of As, Bs, Rs, and Ls to denote which square moves into the empty position. A denotes that the square above the empty position moves; B denotes that the square below the empty position moves; L denotes that the square to the left of the empty position moves; R denotes that the square to the right of the empty position moves. It is possible that there is an illegal move, even when it is represented by one of the 4 move characters. If an illegal move occurs, the puzzle is considered to have no final configuration. This sequence of moves may be spread over several lines, but it always ends in the digit 0. The end of data is denoted by the character Z.

Output

​   Output for each puzzle begins with an appropriately labeled number (Puzzle #1, Puzzle #2, etc.). If the puzzle has no final configuration, then a message to that effect should follow. Otherwise that final configuration should be displayed.

​   Format each line for a final configuration so that there is a single blank character between two adjacent letters. Treat the empty square the same as a letter. For example, if the blank is an interior position, then it will appear as a sequence of 3 blanks — one to separate it from the square to the left, one for the empty position itself, and one to separate it from the square to the right.

​   Separate output from different puzzle records by one blank line.

​   Note: The first record of the sample input corresponds to the puzzle illustrated above.

Sample Input

TRGSJ
XDOKI
M VLN
WPABE
UQHCF
ARRBBL0
ABCDE
FGHIJ
KLMNO
PQRS
TUVWX
AAA
LLLL0
ABCDE
FGHIJ
KLMNO
PQRS
TUVWX
AAAAABBRRRLL0
Z

Sample Output

Puzzle #1:
T R G S J
X O K L I
M D V B N
W P A E
U Q H C F
Puzzle #2:
A B C D
F G H I E
K L M N J
P Q R S O
T U V W X
Puzzle #3:
This puzzle has no final configuration.

HINT

​   这道题真是把我这个菜鸡给整吐了。我不知道如果空格再最后到底会不会录入到数组中,就加上一个判断数组长度,一开始使用gets()结果不可以使用然后自己写了一个类似的对于这个题来说够用的函数来代替,还是不可以。最后看到VJ下面评论说最后一个没有空行,就加上一个判断(设置一个flag1为0,如果是第一次输入就将flag1设置为1,否则在输入之前输出换行),结果还是不行。。。。求大佬指点 我还是个孩子啊,呜呜~

Presentation error

#include<stdio.h>
#include<stdlib.h>
#include<string.h>

void swaps(char* a, char* b)
{
	char t = *a;
	*a = *b;
	*b = t;
}
void ingets(char* s)
{
	int i = 0;
	char temp;
	while (1)
	{
		temp = getchar();
		while(!i&&temp=='\n')temp = getchar();
		if (temp != '\n')
			s[i++] = temp;
		else break;
	}
}
int main()
{
	char arr[5][5];
	int h, k;
	int sum = 0,flag=0;
	int flag1 = 0;
	while (1)
	{
		if (!flag1)flag1++;
		else printf("\n");
		flag = 0;
		for (int i = 0;i < 5;i++)
		{
			memset(arr[i], '\0', 5);
			ingets(arr[i]);
			while (strlen(arr[i])==0)
				ingets(arr[i]);
			if (i == 0 && arr[i][0] == 'Z')
			{
				exit(0);
				flag = 1;
				break;
			}
			if (strlen(arr[i]) == 4)
				arr[i][4] = ' ';
			for (int j = 0;j < 5;j++)
			{
				if (arr[i][j] == ' ')
				{
					h = i;
					k = j;
				}
			}
		}
		if (flag==1)break;
		char move;
		while (1)
		{
			move = getchar();
			if (move == '0')break;
			if (move == 'A')
			{
				if (h == 0)
				{
					flag = 1;
					while(move!='0')
						move = getchar();
					break;
				}
				
				swaps(&arr[h][k], &arr[h-1][k]);
				h--;
			}
			else if (move == 'B')
			{
				if (h == 4)
				{
					flag = 1;
					while (move != '0')
						move = getchar();
					break;
				}
				swaps(&arr[h][k], &arr[h+1][k]);
				h++;
			}
			else if (move == 'L')
			{
				if (k == 0)
				{
					flag = 1;
					while (move != '0')
						move = getchar();
					break;
				}
				swaps(&arr[h][k], &arr[h][k-1]);
				k--;
			}
			else if (move == 'R')
			{
				if (k == 4)
				{
					flag = 1;
					while (move != '0')
						move = getchar();
					break;
				}
				swaps(&arr[h][k], &arr[h][k+1]);
				k++;
			}
		}
		if (flag)
			printf("Puzzle #%d:\nThis puzzle has no final configuration.", ++sum);
		else
		{
			printf("Puzzle #%d:\n", ++sum);
			for (int i = 0;i < 5;i++)
				printf("%c %c %c %c %c\n", arr[i][0], arr[i][1], arr[i][2], arr[i][3], arr[i][4]);
		}
	}
	
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

就很好(*^_^*)

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值