Andy‘s First Dictionary UVA - 10815

  Andy, 8, has a dream - he wants to produce his very own dictionary. This is not an easy task for him, as the number of words that he knows is, well, not quite enough. Instead of thinking up all the words himself, he has a briliant idea. From his bookshelf he would pick one of his favourite story books, from which he would copy out all the distinct words. By arranging the words in alphabetical order, he is done! Of course, it is a really time-consuming job, and this is where a computer program is helpful.
就很好(*_*)

  You are asked to write a program that lists all the different words in the input text. In this problem, a word is defined as a consecutive sequence of alphabets, in upper and/or lower case.

  Words with only one letter are also to be considered. Furthermore, your program must be CaSe InSeNsItIvE. For example, words like “Apple”, “apple” or “APPLE” must be considered the same.

Input

  The input file is a text with no more than 5000 lines. An input line has at most 200 characters. Input is terminated by EOF.

Output

  Your output should give a list of different words that appears in the input text, one in a line. The words should all be in lower case, sorted in alphabetical order. You can be sure that he number of distinct words in the text does not exceed 5000.

Sample Input

Adventures in Disneyland
Two blondes were going to Disneyland when they came to a fork in the
road. The sign read: "Disneyland Left."
So they went home.

Sample Output

a
adventures
blondes
came
disneyland
fork
going
home
in
left
read
road
sign
so
the
they
to
two
went
were
when

HINT

这个题就是让自己来学会是使用set容器的,解释都是注释里面

Accepted

#include<algorithm>
#include <iostream>
#include<sstream>
#include<set>
#include<string>
using namespace std;

set<string>dict;

int main()
{
	string s, buf;											//存储每一个单词
	while (cin >> s)
	{
		for (int i = 0;i < s.length();i++)
			if (isalpha(s[i]))s[i] = towlower(s[i]);		//判断是否是字母并将字母小写形式重新赋给自己
			else s[i] = ' ';								//标点符号变为空格
		stringstream ss(s);									//将s赋给ss;
		while (ss >> buf)									//将ss一个单词一个单词的赋给buf
			dict.insert(buf);								//将单词插入到set容器里面,set容器会自动排序从小到大
	}
	for (set<string>::iterator it = dict.begin();it != dict.end();++it)		//.begin()返回的是一个迭代器类型,类似于指针
		cout << *it << endl;								//输出单词
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

就很好(*^_^*)

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值