The SetStack Computer UVA - 12096

  Background from Wikipedia: “Set theory is a branch of mathematics created principally by the German mathematician Georg Cantor at the end of the 19th century. Initially controversial, set theory has come to play the role of a foundational theory in modern mathematics, in the sense of a theory invoked to justify assumptions made in mathematics concerning the existence of mathematical objects (such as numbers or functions) and their properties. Formal versions of set theory also have a foundational role to play as specifying a theoretical ideal of mathematical rigor in proofs.”

  Given this importance of sets, being the basis of mathematics, a set of eccentric theorist set off to construct a supercomputer operating on sets instead of numbers. The initial SetStack Alpha is under construction, and they need you to simulate it in order to verify the operation of the prototype.

   The computer operates on a single stack of sets, which is initially empty. After each operation, the cardinality of the topmost set on the stack is output. The cardinality of a set S is denoted |S| and is the number of elements in S. The instruction set of the SetStack Alpha is PUSH, DUP, UNION, INTERSECT, and ADD.

  • PUSH will push the empty set {} on the stack.

  • DUP will duplicate the topmost set (pop the stack, and then push that set on the stack twice).

  • UNION will pop the stack twice and then push the union of the two sets on the stack.

  • INTERSECT will pop the stack twice and then push the intersection of the two sets on the stack.

  • ADD will pop the stack twice, add the first set to the second one, and then push the resulting set on the stack.

For illustration purposes, assume that the topmost element of the stack is

A = {{},{{}}}

and that the next one is

B = {{},{{{}}}}

For these sets, we have |A| = 2 and |B| = 2. Then:

  • UNION would result in the set {{}, {{}}, {{{}}}}. The output is 3.

  • INTERSECT would result in the set {{}}. The output is 1.

  • ADD would result in the set {{}, {{{}}}, {{},{{}}}}. The output is 3.

Input

  An integer 0 ≤ T ≤ 5 on the first line gives the cardinality of the set of test cases. The first line of each test case contains the number of operations 0 ≤ N ≤ 2000. Then follow N lines each containing one of the five commands. It is guaranteed that the SetStack computer can execute all the commands in the sequence without ever popping an empty stack.

Output

  For each operation specified in the input, there will be one line of output consisting of a single integer. This integer is the cardinality of the topmost element of the stack after the corresponding command has executed. After each test case there will be a line with ‘***’ (three asterisks).

Sample Input

2
9
PUSH
DUP
ADD
PUSH
ADD
DUP
ADD
DUP
UNION
5
PUSH
PUSH
ADD
PUSH
INTERSECT

Sample Output

0
0
1
0
1
1
2
2
2
***
0
0
1
0
0
***

HINT

  自己比较菜,C++才刚开始学就上容器之类的有点懵,这几个例题都是抄紫皮书上的,主要是学习里面没讲过的操作吧。下面主要说一下自己感觉不是很好理解的地方吧。

  • 空集的表示:set() set加上一个括号就可以表示一个空集了
  • 求并集函数: set_union(A.begin,A.end,B.begin,B.end,inserter(x,x.begin()))。前四个分别是两个集合的区间范围,最后两个是一个插入迭代器,元素将被插入到迭代器所表示的元素之前。又得可以接受5个参数得,但目前还是个菜鸡解释不了,查了查资料set就用插入迭代器了,以后学到再补上。
  • 求交集函数:set_intersection(A.begin,A.end,B.begin,B.end,inserter(x,x.begin()))。参数和上一个一样。

这个题的思路就是用map分配ID


Accepted

#include<algorithm>
#include <iostream>
#include<sstream>
#include<map>
#include<string>
#include<vector>
#include<set>
#include<stack>

using namespace std;

#define ALL(x) x.begin(),x.end()
#define INS(x) inserter(x,x.begin())

typedef set<int>Set;
map<Set, int>IDcache;
vector<Set>Setcache;

int ID(Set x)
{
	if (IDcache.count(x))return IDcache[x];
	Setcache.push_back(x);
	return IDcache[x] = Setcache.size() - 1;
}

int main()
{
	int m, n;
	string ss;
	cin >> m;
	while (m--)
	{
		cin >> n;
		stack<int>s;
		while(n--)
		{
			cin >> ss;
			if (ss == "PUSH")s.push(ID(Set()));
			else if (ss == "DUP")s.push(s.top());
			else {
				Set x1 = Setcache[s.top()];s.pop();
				Set x2 = Setcache[s.top()];s.pop();
				Set x;
				if (ss == "UNION")set_union(ALL(x1),ALL(x2),INS(x));
				if (ss == "INTERSECT")set_intersection(ALL(x1), ALL(x2), INS(x));
				if (ss == "ADD") {
					x = x2;
					x.insert(ID(x1));
				}
				s.push(ID(x));
			}
			cout << Setcache[s.top()].size() << endl;

		}
		cout << "***" << endl;
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

就很好(*^_^*)

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值