Goldbach‘s Conjecture 哥德巴赫猜想

该程序实现了一个简单的算法,用于验证哥德巴赫猜想,即检查小于一百万的所有偶数是否能表示为两个奇素数之和。如果找到满足条件的素数对,它会输出这两个素数,且优先选择差值最大的一对。如果无法找到这样的素数对,程序将提示‘Goldbach’s conjecture is wrong.’。
摘要由CSDN通过智能技术生成

Goldbach’s Conjecture

Problem Description
In 1742, Christian Goldbach, a German amateur mathematician, sent a letter to Leonhard Euler in which he made the following conjecture:
Every even number greater than 4 can be
written as the sum of two odd prime numbers.

For example:
8 = 3 + 5. Both 3 and 5 are odd prime numbers.
20 = 3 + 17 = 7 + 13.
42 = 5 + 37 = 11 + 31 = 13 + 29 = 19 + 23.

Today it is still unproven whether the conjecture is right. (Oh wait, I have the proof of course, but it is too long to write it on the margin of this page.)
Anyway, your task is now to verify Goldbach’s conjecture for all even numbers less than a million.

Input
The input will contain one or more test cases.
Each test case consists of one even integer n with 6 <= n < 1000000.
Input will be terminated by a value of 0 for n.

Output
For each test case, print one line of the form n = a + b, where a and b are odd primes. Numbers and operators should be separated by exactly one blank like in the sample output below. If there is more than one pair of odd primes adding up to n, choose the pair where the difference b - a is maximized. If there is no such pair, print a line saying “Goldbach’s conjecture is wrong.”

Sample Input
8
20
42
0

Sample Output
8 = 3 + 5
20 = 3 + 17
42 = 5 + 37

题目大意:哥德巴赫猜想给出一个大于4的偶数,都可以写成两个素数的和。要求输入一个偶数n,输出和为n的两个素数,如果有多组满足,则输出两个素数差最大的那一对。

可以素数打表,然后从2开始判断 i 是否为素数,以及 n-i 是否为素数,如果都是,则得到的 i 和n-i即为差最大的一组素数。

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#define N 1000010

int p[N];

void IsPrime()
{
    memset(p,0,sizeof(p));//假设所有数都为素数
    for(int i = 2; i<N; i++)
    {
        if(!p[i])//如果i 是素数,则i 的倍数都为非素数
            for(int j = i+i; j<=N; j+=i)
            {
                p[j] = 1;//非素数
            }
    }
    /*测试
    for(int i = 1; i<N; i++)
        if(!p[i])
        printf("%d\t",i);
    */
}

int main()
{
    IsPrime();//提前打表
    int n,a,b;
    while(~scanf("%d",&n) && n)
    {
        a = 0;
        b = 0;
        for(int i = 2; i<n; i++)
        {
            if(!p[i] && !p[n-i])
            {
                a = i;
                b = n-i;
                break;
            }
        }
        if(!a && !b)
            printf("Goldbach's conjecture is wrong.\n");
        else
            printf("%d = %d + %d\n",n,a,b);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值