PAT 1054 求平均值 (20分) (python 3)(代码+坑点)

本题的基本要求非常简单:给定 N 个实数,计算它们的平均值。但复杂的是有些输入数据可能是非法的。一个“合法”的输入是 [−1000,1000] 区间内的实数,并且最多精确到小数点后 2 位。当你计算平均值的时候,不能把那些非法的数据算在内。
输入格式:

输入第一行给出正整数 N(≤100)。随后一行给出 N 个实数,数字间以一个空格分隔。
输出格式:

对每个非法输入,在一行中输出 ERROR: X is not a legal number,其中 X 是输入。最后在一行中输出结果:The average of K numbers is Y,其中 K 是合法输入的个数,Y 是它们的平均值,精确到小数点后 2 位。如果平均值无法计算,则用 Undefined 替换 Y。如果 K 为 1,则输出 The average of 1 number is Y。
输入样例 1:

7
5 -3.2 aaa 9999 2.3.4 7.123 2.35

输出样例 1:

ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38

输入样例 2:

2
aaa -9999

输出样例 2:

ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined

第一版代码:

N=int(input())
temp=input().split()
num=[]
for t in temp:
    if t.isalpha() or t.count('.')>1 or t=='-':
        print("ERROR: {} is not a legal number".format(t))
        continue
    a=str(float(t)).split('.')
    if float(t)<-1000 or float(t)>1000 or len(a[1])>2:
        print("ERROR: {} is not a legal number".format(t))
        continue
    num.append(float(t))
k=len(num)
if k==0:
    print("The average of 0 numbers is Undefined")
elif k==1:
    print("The average of 1 number is {:.2f}".format(sum(num)/k))
else:
    print("The average of {} numbers is {:.2f}".format(k,sum(num)/k))

坑点

1、测试点3:注意边界:(-)1000要注意小数部分的情况
2、测试点2:注意k=1的时候,是number 不是numbers,这个搞了我半天
3、注意只有‘-’的情况

第二版

import re
def judge(t):
    str=r'^[-]?(\d{0,3}|1000)$|^[-]?\d{0,3}\.\d{0,2}$|^[-]?1000\.0{0,2}$'
    m=re.match(str,t)
    if m:
        return 1
    return 0
# n=input()
# print(judge(n))
N=int(input())
temp=input().split()
num=[]
for t in temp:
    f=judge(t)
    if t!='-' and f==1:
        num.append(float(t))
    else:
        print("ERROR: {} is not a legal number".format(t))
k=len(num)
if k==0:
    print("The average of 0 numbers is Undefined")
elif k==1:
    print("The average of 1 number is {:.2f}".format(sum(num)/k))
else:
    print("The average of {} numbers is {:.2f}".format(k,sum(num)/k))

这是参考了大佬的代码,正则用起来确实方便

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值