ice_cream’s world is a rich country, it has many fertile lands. Today, the queen of ice_cream wants award land to diligent ACMers. So there are some watchtowers are set up, and wall between watchtowers be build, in order to partition the ice_cream’s world. But how many ACMers at most can be awarded by the queen is a big problem. One wall-surrounded land must be given to only one ACMer and no walls are crossed, if you can help the queen solve this problem, you will be get a land.
Input
In the case, first two integers N, M (N<=1000, M<=10000) is represent the number of watchtower and the number of wall. The watchtower numbered from 0 to N-1. Next following M lines, every line contain two integers A, B mean between A and B has a wall(A and B are distinct). Terminate by end of file.
Output
Output the maximum number of ACMers who will be awarded.
One answer one line.
Sample Input
8 10
0 1
1 2
1 3
2 4
3 4
0 5
5 6
6 7
3 6
4 7
Sample Output
3
这一题就是给你n个地方,再给你m组数据,是两个相接的城市,然后让你找这n个城市被分为了多少个互不相连的地方,这就是让你查找有多少个环。使用并查集的知识就是把每两个点归为一个集合,再判断是否存在组合,要是有就归进一个里面。
下面是代码部分:`
#include<stdio.h>
#include<string.h>
using namespace std;
int book[1010];
int li(int k)
{
if(book[k]!=k)
{
book[k]=li(book[k]);
}
return book[k];
}
int main()
{
int m,n;
while(~scanf("%d %d",&m,&n))
{
int a,b,i,j,x,y;
int sum=0;
for(i=0;i<m;i++)
{
book[i]=i;
}
for(i=0;i<n;i++)
{
scanf("%d %d",&a,&b);
x=li(a);
y=li(b);
if(x==y&&a!=b)
{
sum++;
}
book[y]=x;
}
printf("%d\n",sum);
}
return 0;
}