D - Subsequence(尺取法)

题目:
A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.
Input
The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.
Output
For each the case the program has to print the result on separate line of the output file.if no answer, print 0.
Sample Input
2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5
Sample Output
2
3

题意:给出有N个数字,找他的一个最短子序列使得子序列和>=S
尺取法

尺取法通常是指对数组保存一对下标(起点,终点),然后根据实际情况交替推进两个端点直到得出答案的方法!

对于这个题目,右端点移动到序列和大于等于S后就移动一下左端点减去一个数,看看是不是还符合要求,在移动的过程中,如果出现更小的区间就更新result。

#include<iostream>
using namespace std;
int a[100005];
int fun_sum(int* t, int left, int right) {
	int sum = 0;
	for (int i = left; i <= right; i++)
		sum += t[i];
	return sum;
}
int main()
{
	int _n;
	cin >> _n;
	while (_n--) {
		int n, s;
		int result = 0x7fffffff;
		cin >> n >> s;
		for (int i = 1; i <= n; i++)
			cin >> a[i];

		int left = 0, right = 0;
		bool first = true;
		int sum = 0;
		for (left = 0, right = 0; right <= n;right++) {
			//int sum = fun_sum(a,left,right);
			if(sum<s)sum += a[right];
			if (first&&sum>=s) { first = false; result = right-left+1; }
			if (result>(right-left+1)&&sum>=s)result = right-left+1;

			if (sum >= s) {
				sum -= a[left];
				left++;
				if (sum >= s)right--;/*减去left sum依旧大于s,right不动*/
			}
		}
		if (first)cout << "0" << endl;
		else cout << result << endl;
	}
	return 0;
}

优化:
第一遍的时候写了一个指定区间求和的函数,这样很浪费时间。
其实每次移动的时候,右端点移动就加一个数,左端点移动就减一个数。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值