A1067 Sort with Swap(0, i)(25分)PAT甲级 (Advanced Level) Practice(C++)满分题解【swap排序】

Input Specification:

Each input file contains one test case, which gives a positive N (≤105) followed by a permutation sequence of {0, 1, ..., N−1}. All the numbers in a line are separated by a space.

Output Specification:

For each case, simply print in a line the minimum number of swaps need to sort the given permutation.

Sample Input:

10
3 5 7 2 6 4 9 0 8 1

Sample Output:

9

代码如下:

#include<iostream>
using namespace std;
int a[100010];//数字i所在的位置
int main()
{
    int n,t,count=0;
    cin>>n;
    for(int i=0;i<n;i++)
    {
        cin>>t;
        a[t]=i;//数字t在第i个位置上
    }
    for(int i=0;i<n;i++)
    {
        if(a[i]!=i)
        {
            while(a[0]!=0)
            {
                swap(a[0],a[a[0]]);
                count++;
            }
            if(a[i]!=i){
                swap(a[0],a[i]);
                count++;
            }
        }
    }
    cout<<count<<endl;
    return 0;
}

运行结果如下:

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值