A1102 Invert a Binary Tree(25分)PAT 甲级(Advanced Level) Practice(C++)满分题解【反转二叉树+层序遍历+中序遍历】

该博客介绍了一段C++代码,用于解决给定一棵二叉树,将其节点值反转并输出层次遍历和中序遍历序列的问题。代码首先定义了节点结构,然后实现了层次遍历和中序遍历的递归函数。最后,通过比较节点深度对层次遍历进行排序。
摘要由CSDN通过智能技术生成

The following is from Max Howell @twitter:

Google: 90% of our engineers use the software you wrote (Homebrew), but you can't invert a binary tree on a whiteboard so fuck off.

Now it's your turn to prove that YOU CAN invert a binary tree!

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node from 0 to N−1, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in the first line the level-order, and then in the second line the in-order traversal sequences of the inverted tree. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:

8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6

Sample Output:

3 7 2 6 4 0 5 1
6 5 7 4 3 2 0 1

代码如下:

#include<iostream>
#include<string>
#include<vector>
#include<algorithm>
using namespace std;
struct Node{
    int value,left,right,index,depth;
}node[10];
bool havefather[10];
vector<Node> levellist,inlist;
void inOrder(int root,int index,int depth)
{
    if(node[root].right!=-1)inOrder(node[root].right,2*index+2,depth+1);
    inlist.push_back({root,0,0,index,depth});
    if(node[root].left!=-1)inOrder(node[root].left,2*index+1,depth+1);
}
bool cmp(Node a,Node b)
{
    if(a.depth!=b.depth)return a.depth<b.depth;
    else return a.index>b.index;
}
int main()
{
    int n,root;
    cin>>n;
    for(int i=0;i<n;i++){
        string s1,s2;
        cin>>s1>>s2;
        if(s1=="-")node[i].left=-1;
        else node[i].left=stoi(s1);
        if(s2=="-")node[i].right=-1;
        else node[i].right=stoi(s2);
    }
    for(int i=0;i<n;i++)
    {
        if(node[i].left!=-1)havefather[node[i].left]=true;
        else havefather[node[i].left]=false;
        if(node[i].right!=-1)havefather[node[i].right]=true;
        else havefather[node[i].right]=false;
    }
    //find the root Node
    for(int i=0;i<n;i++)
    {
        if(!havefather[i]){
            root=i;
            break;
        }
    }
    inOrder(root,0,0);
    levellist=inlist;
    sort(levellist.begin(),levellist.end(),cmp);
    
    cout<<levellist[0].value;
    for(int i=1;i<n;i++)
        cout<<" "<<levellist[i].value;
    cout<<endl;

    cout<<inlist[0].value;
    for(int i=1;i<n;i++)
        cout<<" "<<inlist[i].value;
    cout<<endl;
}

运行结果如下:

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值