1116 Come on! Let‘s C (20分)——C语言实现

1116 Come on! Let’s C (20分)

“Let’s C” is a popular and fun programming contest hosted by the College of Computer Science and Technology, Zhejiang University. Since the idea of the contest is for fun, the award rules are funny as the following:

0、 The Champion will receive a “Mystery Award” (such as a BIG collection of students’ research papers…).
1、 Those who ranked as a prime number will receive the best award – the Minions (小黄人)!
2、 Everyone else will receive chocolates.
Given the final ranklist and a sequence of contestant ID’s, you are supposed to tell the corresponding awards.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10000), the total number of contestants. Then N lines of the ranklist follow, each in order gives a contestant’s ID (a 4-digit number). After the ranklist, there is a positive integer K followed by K query ID’s.

Output Specification:

For each query, print in a line ID: award where the award is Mystery Award, or Minion, or Chocolate. If the ID is not in the ranklist, print Are you kidding? instead. If the ID has been checked before, print ID: Checked.

Sample Input:

6
1111
6666
8888
1234
5555
0001
6
8888
0001
1111
2222
8888
2222

Sample Output:

8888: Minion
0001: Chocolate
1111: Mystery Award
2222: Are you kidding?
8888: Checked
2222: Are you kidding?

学习:

该题我的主要收获是在编译器方面。我是使用VC2010,在用到根植函数sqrt()时,发现有错误,后来查阅资料发现,2010在sqrt()这里比较严格,括号里面必须是double或者float类型,所以如果是其他类型,需要强制类型转换。

代码:

#include<stdio.h>
#include<math.h>
int a[10010]={0};
char rewards[6][100] = {"Are you kidding?","Mystery Award","Minion","Chocolate","Checked"};

int primeN(int x){
	int i;
	int q=sqrt((float)x);
	for(i=2;i<=q;i++){
		if(x%i==0)
			break;
	}
	if(i>q)
		return 1;
	else
		return 0;
}
int main(){
	int n,i,N;
	scanf("%d",&n);
	for(i=1;i<=n;i++){
		int temp;
		scanf("%d",&temp);
		if(i==1)
			a[temp]=1;
		else if(primeN(i))
			a[temp]=2;
		else
			a[temp]=3;
	}
	scanf("%d",&N);
	for(i=1;i<=N;i++){
		int temp;
		scanf("%d",&temp);
		printf("%04d: %s\n",temp,rewards[a[temp]]);
		if(a[temp]>0)
			a[temp]=4;
	}
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

21岁被迫秃头

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值