1115 Counting Nodes in a BST (30分)——C/C++

1115 Counting Nodes in a BST (30分)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  1. The left subtree of a node contains only nodes with keys less than or equal to the node’s key.
  2. The right subtree of a node contains only nodes with keys greater than the node’s key.
  3. Both the left and right subtrees must also be binary search trees.

Insert a sequence of numbers into an initially empty binary search tree. Then you are supposed to count the total number of nodes in the lowest 2 levels of the resulting tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤1000) which is the size of the input sequence. Then given in the next line are the N integers in [−1000,1000] which are supposed to be inserted into an initially empty binary search tree.

Output Specification:

For each case, print in one line the numbers of nodes in the lowest 2 levels of the resulting tree in the format:

n1 + n2 = n

where n1 is the number of nodes in the lowest level, n2 is that of the level above, and n is the sum.

Sample Input:

9
25 30 42 16 20 20 35 -5 28

Sample Output:

2 + 4 = 6

题目大意:

我的代码主要还是c语言,只在能简化的地方使用了c++。给出n个结点,构建二叉搜索树。即小于等于根结点的数据放在左子树,大于根结点的数据放在右子树,并且其左右子树也要符合这个规律。输出最后一层结点个数n1 + 倒数第二层结点个数n2 之和。

错误:

在一开始,我的第五个测试点一直通不过,后来发现忽略了只有根结点的情况,下面有错误代码和正确代码,希望能给大家一点启发。

错误代码:

#include <stdio.h>
#include <malloc.h>
#include <algorithm>
using namespace std;

typedef struct Node{
	int id;
	struct Node *right,*left;
}node;

int a[1010]={0};
int j=0;

node *Insert(node *root,int temp){
	node *s,*p,*q;
	s=(node *)malloc(sizeof(node));
	s->id=temp;
	s->left=s->right=NULL;
	p=root;
	if(p==NULL){
		root=s;
		a[j]++;
		return root;
	}
	while(p!=NULL){
		q=p;
		a[j]++;
		if(temp<=p->id){
			p=p->left;
		}
		else{
			p=p->right;
		}
	}
	if(temp<=q->id){
		q->left=s;
		a[j]++;
	}
	else{
		q->right=s;
		a[j]++;
	}
	return root;
}

bool compare(int a,int b)
{
    return a>b;
}
int main(){
	int n,i;
	node *root=NULL;
	scanf("%d",&n);
	for(i=0;i<n;i++){
		int temp;
		scanf("%d",&temp);
		root=Insert(root,temp);
		j++;
	}
	sort(a,a+n,compare);
	int n1=1,n2=1;
	int flag=a[0];
	for(i=1;i<n;i++){
		if(a[i]==flag)
			n1++;
		else{
			if(a[i]==a[i+1])
				n2++;
			else
				break;
		}
	}
	printf("%d + %d = %d",n1,n2,n1+n2);
	return 0;
}

修改代码:

#include <stdio.h>
#include <malloc.h>
#include <algorithm>
using namespace std;

typedef struct Node{
	int id;
	struct Node *right,*left;
}node;

int a[1010]={0};
int j=0;

node *Insert(node *root,int temp){
	node *s,*p,*q;
	s=(node *)malloc(sizeof(node));
	s->id=temp;
	s->left=s->right=NULL;
	p=root;
	if(p==NULL){
		root=s;
		a[j]++;
		return root;
	}
	while(p!=NULL){
		q=p;
		a[j]++;
		if(temp<=p->id){
			p=p->left;
		}
		else{
			p=p->right;
		}
	}
	if(temp<=q->id){
		q->left=s;
		a[j]++;
	}
	else{
		q->right=s;
		a[j]++;
	}
	return root;
}

bool compare(int a,int b)
{
    return a>b;
}
int main(){
	int n,i;
	node *root=NULL;
	scanf("%d",&n);
	for(i=0;i<n;i++){
		int temp;
		scanf("%d",&temp);
		root=Insert(root,temp);
		j++;
	}
	sort(a,a+n,compare);
	int n1=1,n2=1;
	int flag=a[0];
	for(i=1;i<n;i++){
		if(a[i]==flag)
			n1++;
		else{
			if(a[i]==a[i+1])
				n2++;
			else
				break;
		}
	}
	if(n==1)
		printf("1 + 0 = 0");
	else
	    printf("%d + %d = %d",n1,n2,n1+n2);
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

21岁被迫秃头

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值