1118 Birds in Forest (25分)——C语言实现(并查集)

1118 Birds in Forest (25分)

Some scientists took pictures of thousands of birds in a forest. Assume that all the birds appear in the same picture belong to the same tree. You are supposed to help the scientists to count the maximum number of trees in the forest, and for any pair of birds, tell if they are on the same tree.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (≤10^​4) which is the number of pictures. Then N lines follow, each describes a picture in the format:

K B ​1 ​​ B ​2 ​​ … B ​K ​​

where K is the number of birds in this picture, and Bi’s are the indices of birds. It is guaranteed that the birds in all the pictures are numbered continuously from 1 to some number that is no more than 10​^4.

After the pictures there is a positive number Q (≤10^4) which is the number of queries. Then Q lines follow, each contains the indices of two birds.

Output Specification:

For each test case, first output in a line the maximum possible number of trees and the number of birds. Then for each query, print in a line Yes if the two birds belong to the same tree, or No if not.

Sample Input:

4
3 10 1 2
2 3 4
4 1 5 7 8
3 9 6 4
2
10 5
3 7

Sample Output:

2 10
Yes
No

题目大意:

给定图片个数N,下面每一行第一个数字为该图片上鸟的个数K,后面为鸟的编号。如果在不同图片上鸟的编号相同,就认为是同一棵树。求树的个数和鸟的个数。最后给出Q个查询,求这对鸟是否在同一棵树上。

思路:

对于鸟的数量可以用一个数组a[ ]来标记是否已经计数;对于树的个数可以用鸟的个数减去并查集合并次数,即为树的个数;最后的查询只需查询两只鸟的根结点是否相同即可。

代码:

#include<stdio.h>
#define maxn 10005
int a[maxn],fat[maxn],b[maxn]={0};
int count=0;
int Root(int x){//寻找x的根结点,当一个顶点的根节点是它本身,说明就是根结点
	if(fat[x]!=x)
	    return Root(fat[x]);
	else
	    return x;
}

void Unionn(int x,int y){//加入集合,并查集的一部分
	count++;
	if(b[x]>b[y])
		fat[y]=x;
	else if(b[x]<b[y])
		fat[x]=y;
	else{
		fat[y]=x;
		b[x]++;
	}
}

int main(){
	int n,i,birds=0;
	int k,b0,b;
	scanf("%d",&n);
	for(i=1;i<=maxn;i++){
		fat[i]=i;
	}
	for(i=0;i<n;i++){
		scanf("%d %d",&k,&b0);
		if(!a[b0]){
			a[b0]=-1;
			birds++;
		}
		for(int j=1;j<k;j++){
			scanf("%d",&b);
			int x,y;
			x=Root(b);
			y=Root(b0);
			if(x!=y)
				Unionn(x,y);
			if(!a[b]){
			    a[b]=-1;
			    birds++;
		    }
		}
	}
	int Q,b1,b2;
	scanf("%d",&Q);
	printf("%d %d\n",birds-count,birds);
	for(i=0;i<Q;i++){
		scanf("%d %d",&b1,&b2);
		if(Root(b1)==Root(b2))
			printf("Yes\n");
		if(Root(b1)!=Root(b2))
			printf("No\n");
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

21岁被迫秃头

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值