(运动会最后一天啦~)1024 Palindromic Number (25 分)

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.

Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.

向前或向后书写时相同的数字称为回文数字。例如,1234321是回文数字。所有单个数字都是回文数字。

非回文数字可以通过一系列操作与回文数字配对。首先,反转非回文数,并将结果添加到原始数字。如果结果不是回文数,则重复这一过程,直到它给出回文数。例如,如果我们从67开始,我们可以分两步获得回文数:67 + 76 = 143,143 + 341 = 484。

给出任何正整数 N,你应该找到它的配对回文数和找到它的步骤数。

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and K, where N (≤10​10​​) is the initial numer and K (≤100) is the maximum number of steps. The numbers are separated by a space.

Output Specification:

For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps, just output the number obtained at the Kth step and K instead.

给定数字判断回文,是就输出0次,不是就一直翻转相加,超过给定次数,输出给定次数翻转相加后的结果并输出给定次数,在给定次数内找到了,输出该数和次数。

Sample Input 1:

67 3

Sample Output 1:

484
2

Sample Input 2:

69 3

Sample Output 2:

1353
3
#include<iostream>
#include<algorithm>
using namespace std;
string n;///大整数n以字符串形式输入
void add(string t)
{///大整数相加
    int len=n.length(),cnt=0;///cnt进位
    for(int len-1;i>=0;i--)
    {
        n[i]=n[i]+t[i]+cnt-'0';///第一位开始正向相加
        cnt=0;///每次相加后进位都得归0
        if(n[i]>'9')
        {
            n[i]-=10;
            cnt=1;///进一位
        }
    }
    if(cnt)n+='1';///还有进位就在右边加1
    reverse(n.begin(),n.end());///倒置后才是正常结果
}
int main()
{
    int k,i;
    cin>>n>>k;
    for(i=0;i<=k;i++)
    {
        string t=n;///复制字符串
        reverse(t.begin(),t.end());///翻转验证回文
        if(n==t||i==k)break;///找到或者到给定次数没找到都要退出
        add(t);///没找到继续找(传入的是翻转后的n)
    }
    cout<<n<<endl<<i;///输出和,次数
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值