C L2-009 抢红包 (25 分)

没有人没抢过红包吧…… 这里给出N个人之间互相发红包、抢红包的记录,请你统计一下他们抢红包的收获。

输入格式:

输入第一行给出一个正整数N(≤104),即参与发红包和抢红包的总人数,则这些人从1到N编号。随后N行,第i行给出编号为i的人发红包的记录,格式如下:

KN1​P1​⋯NK​PK​

其中K(0≤K≤20)是发出去的红包个数,Ni​是抢到红包的人的编号,Pi​(>0)是其抢到的红包金额(以分为单位)。注意:对于同一个人发出的红包,每人最多只能抢1次,不能重复抢。

输出格式:

按照收入金额从高到低的递减顺序输出每个人的编号和收入金额(以元为单位,输出小数点后2位)。每个人的信息占一行,两数字间有1个空格。如果收入金额有并列,则按抢到红包的个数递减输出;如果还有并列,则按个人编号递增输出。

输入样例:

10
3 2 22 10 58 8 125
5 1 345 3 211 5 233 7 13 8 101
1 7 8800
2 1 1000 2 1000
2 4 250 10 320
6 5 11 9 22 8 33 7 44 10 55 4 2
1 3 8800
2 1 23 2 123
1 8 250
4 2 121 4 516 7 112 9 10

输出样例:

1 11.63
2 3.63
8 3.63
3 2.11
7 1.69
6 -1.67
9 -2.18
10 -3.26
5 -3.26
4 -12.32
#include<bits/stdc++.h>
using namespace std;
#define Max 100

struct People{
	int number;//编号; 
	int k;//发出的红包数;
	int l = 0;//抢到的红包数; 
	int money[Max] = {0};//抢到红包的人编号和金额,下标表示编号;
	int cost = 0;//发出红包金额; 
	int income = 0;//抢到的红包金额; 
	double sum = 0.0;//总收入; 
};

bool compare(People a,People b){
	if(a.sum != b.sum){
		return a.sum > b.sum;//先按收入降序排列; 
	}else{
		if(a.l!=b.l){
			return a.l > b.l;//若相同按抢红包个数降序排列; 
		}else{
			return a.number < b.number;//若再相同按序号升序排列; 
		}	
	}
}

int main(){
	int n;
	cin >> n; 
	People people[n];
	for(int i=0;i<n;i++){
		people[i].number = i + 1; 
		cin >> people[i].k;
		for(int j=0;j<people[i].k;j++){
			int a,b;
			cin >> a >> b;
			people[i].money[a] = b;
			people[i].cost += b;
			people[a-1].income += b;
			people[a-1].l++;
		}	
	}
	for(int i=0;i<n;i++){
		people[i].sum = (people[i].income - people[i].cost) / 100.0;
	}
	
	sort(people,people+n,compare);
	for(int i=0;i<n;i++){
		cout << people[i].number << " " << people[i].sum << endl;
	}
	return 0;
}

!!!!有个问题想请求帮忙,测试案列跑出来了,可是评测却0分,有谁能看出是什么毛病吗

已得到帮助,修改后如下 ,具体原因是因为没控制小数点位数,虽然之前输出时自动截取了后两位,但仍需手动控制位数!

#include<bits/stdc++.h>
using namespace std;

struct People{
	int number;//编号; 
	int k;//发出的红包数;
	int l = 0;//抢到的红包数; 
	int cost = 0;//发出红包金额; 
	int income = 0;//抢到的红包金额; 
	double sum = 0.0;//总收入; 
};

bool compare(People a,People b){
	if(a.sum != b.sum){
		return a.sum > b.sum;//先按收入降序排列; 
	}else{
		if(a.l!=b.l){
			return a.l > b.l;//若相同按抢红包个数降序排列; 
		}else{
			return a.number < b.number;//若再相同按序号升序排列; 
		}	
	}
}
int main(){
	int n;
	cin >> n; 
	People people[n];
	for(int i=0;i<n;i++){
		people[i].number = i + 1; 
		cin >> people[i].k;
		for(int j=0;j<people[i].k;j++){
			int a,b;
			cin >> a >> b;
			people[i].cost += b;
			people[a-1].income += b;
			people[a-1].l++;
		}	
	}
	for(int i=0;i<n;i++){
		people[i].sum = (people[i].income - people[i].cost) / 100.0;
	}
	
	sort(people,people+n,compare);
	for(int i=0;i<n;i++){
		cout << people[i].number << " " ;
        cout << fixed << setprecision(2) << people[i].sum << endl;
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
根据提供的代码和输入输出样例,这段代码是一个解决L2-009 红包问题的程序。该程序接受一个整数n作为输入,表示参与红包的人数。然后依次输入每个人的编号和到的红包金额。程序会根据收入金额从高到低的递减顺序输出每个人的编号和收入金额(以元为单位,输出小数点后2位)。如果收入金额有并列,则按红包的个数递减输出;如果还有并列,则按个人编号递增输出。 对于给定的输入样例10 3 2 22 10 58 8 125 5 1 345 3 211 5 233 7 13 8 101 1 7 8800 2 1 1000 2 1000 2 4 250 10 320 6 5 11 9 22 8 33 7 44 10 55 4 2 1 3 8800 2 1 23 2 123 1 8 250 4 2 121 4 516 7 112 9 10,程序的输出样例应为1 0.00 2 0.00 3 0.00 4 0.00 5 0.00 6 0.00 7 0.00 8 0.00 9 0.00 10 0.00。 请注意,这段代码使用了C++的标准库函数和算法,包括iostream、algorithm和using namespace std。它还定义了一个Person类,用于存储每个人的编号、收入金额和红包的个数。程序通过对Person对象数组进行排序,按照要求输出每个人的编号和收入金额。 希望这个解释对你有帮助! #### 引用[.reference_title] - *1* *2* *3* [【GPLT 二阶题目集】L2-009 红包](https://blog.csdn.net/DeskOneRice/article/details/128783061)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v91^insert_down1,239^v3^insert_chatgpt"}} ] [.reference_item] [ .reference_list ]

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值