题目描述:
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.
输入:
The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .
输出:
The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.
If no such path exist, you should output impossible on a single line.
输入样例:
3 1 1 2 3 4 3
输出样例:
Scenario #1: A1 Scenario #2: impossible Scenario #3: A1B3C1A2B4C2A3B1C3A4B2C4
解题思路:
想找一条路径遍历完图,只能用深搜,而且深搜时必须一条路径覆盖上图中的所有结点,用一个数组专门记录路径上的结点,直到遍历完整张图。
解题步骤:
1、建立增量数组,把每一步行列号的增量全部保存,便于查找邻接点;建立路径二维数组,第一个下标用于存放步数,第二个下标用于存放行或列,内容是某步遍历的结点的行列的值;
2、定义bool类型变量flag,用于保存是否能够遍历整张图;
3、从0,0点开始深度优先遍历,每次访问原点的邻接点时,记录好此步的行列号,然后递归;直到执行步数 = 图的行数乘以列数为止。
4、若递归后未触发设置的返回条件,说明这条路径不通,需要还原现场,解除结点的访问标记。
代码实现:
#include <iostream>
using namespace std;
#define maxn 27
int m, n;
bool vis[maxn][maxn];
int path[maxn][2]; //记录路径结点
int add[8][2] = { -2, -1, -2, 1, -1, -2, -1, 2, 1, -2, 1, 2, 2, -1, 2 , 1 };
bool flag; //结束标记
void Init()
{
memset(vis, false, sizeof(vis));
}
bool DFS(int u, int v, int step)
{
if (step == n * m)
{
return flag = true;
}
for (int i = 0; i < 8; i++)
{
int u1 = u + add[i][0];
int v1 = v + add[i][1];
if (u1 >= 0 && u1 < n && v1 >= 0 && v1 < m && !vis[u1][v1] && !flag)
{
vis[u1][v1] = true;
path[step][0] = u1;
path[step][1] = v1;
DFS(u1, v1, step + 1);
vis[u1][v1] = false; //还原现场
}
}
return flag;
}
int main()
{
int t;
cin >> t;
for (int i = 1; i <= t; i++)
{
cin >> m >> n;
Init();
flag = false;
path[0][0] = 0;
path[0][1] = 0;
vis[0][0] = true;
cout << "Scenario #" << i << ":" << endl;
if(DFS(0, 0, 1))
{
for (int i = 0; i < m * n; i++)
{
cout << char(path[i][0] + 'A') << path[i][1] + 1;
}
cout << endl;
}
else
{
cout << "impossible" << endl << endl;
}
}
return 0;
}