PAT甲级-1046 Shortest Distance

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:
Each input file contains one test case. For each case, the first line contains an integer N (in [3,10^5]), followed by N integer distances D1 D2 ⋯ DN,where Di is the distance between the i-th and the (i+1)-st exits, and DN
​is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (≤10^4), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 10^7.

Output Specification:
For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:
5 1 2 4 14 9
3
1 3
2 5
4 1

Sample Output:
3
10
7

这道题的大概意思是有一个圆环,有几座城市,输入的第一行数代表了5个城市,后面五个数代表该城市到后一个城市的距离,下面几行是一些要求,从某个城市到某个城市,需要求出最短需要多少距离。
解题思路:由于是环形,所以每个城市到另一个城市都会有两条路,顺时针和逆时针,我们可以用前缀和求两城市之间的距离,即按照所给的这个顺序正着走,再把总的距离求出来,减去正着走的就是另一条路的距离,比较这两个哪个小输出哪个。

#include<iostream>
using namespace std;

int main()
{
	int N,dis[100000],sum[100001];
	cin>>N;sum[1]=0;
	for(int i=0;i<N;i++) cin>>dis[i];
	for(int i=2;i<=N;i++) sum[i]=sum[i-1]+dis[i-2];//前缀和
	int M,a,b,d1,d2;
	cin>>M;
	for(int i=0;i<M;i++) {
		d1=d2=0;
		cin>>a>>b;
		if(a>b) {
			int temp=b;
			b=a;
			a=temp;
		}
		d1=sum[b]-sum[a];
		d2=sum[N]+dis[N-1]-d1;
		if(d1<d2) cout<<d1<<endl;
		else cout<<d1<<endl;
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值