PAT甲级-1041 Be Unique

Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1,10^4]. The first one who bets on a unique number wins. For example, if there are 7 people betting on { 5 31 5 88 67 88 17 }, then the second one who bets on 31 wins.

Input Specification:
Each input file contains one test case. Each case contains a line which begins with a positive integer N (≤10^5) and then followed by N bets. The numbers are separated by a space.

Output Specification:
For each test case, print the winning number in a line. If there is no winner, print None instead.

Sample Input 1:
7 5 31 5 88 67 88 17

Sample Output 1:
31

Sample Input 2:
5 888 666 666 888 888

Sample Output 2:
None

这道题的意思大概是输入一些数,然后在这里面找出第一个独特的数,也就是在这里面只出现一次的数。
解题思路:可以用哈希表,输入的时候让表中对应下标的加一,然后再遍历一次哈希表输出第一个为1的数字。

#include<iostream>
using namespace std;

int main()
{
	int N,num[100000],k[10000];
	cin>>N;
	for(int i=0;i<N;i++) {
		cin>>num[i];
		k[num[i]]++;
	}
	for(int i=0;i<N;i++) {
		if(k[num[i]]==1) {
			cout<<num[i];
			return 0;
		}
	}
	cout<<"None";
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值