PAT甲级-1035 Password

To prepare for PAT, the judge sometimes has to generate random passwords for the users. The problem is that there are always some confusing passwords since it is hard to distinguish 1 (one) from l (L in lowercase), or 0 (zero) from O (o in uppercase). One solution is to replace 1 (one) by @, 0 (zero) by %, l by L, and O by o. Now it is your job to write a program to check the accounts generated by the judge, and to help the juge modify the confusing passwords.

Input Specification:
Each input file contains one test case. Each case contains a positive integer N (≤1000), followed by N lines of accounts. Each account consists of a user name and a password, both are strings of no more than 10 characters with no space.

Output Specification:
For each test case, first print the number M of accounts that have been modified, then print in the following M lines the modified accounts info, that is, the user names and the corresponding modified passwords. The accounts must be printed in the same order as they are read in. If no account is modified, print in one line There are N accounts and no account is modified where N is the total number of accounts. However, if N is one, you must print There is 1 account and no account is modified instead.

Sample Input 1:
3
Team000002 Rlsp0dfa
Team000003 perfectpwd
Team000001 R1spOdfa

Sample Output 1:
2
Team000002 RLsp%dfa
Team000001 R@spodfa

Sample Input 2:
1
team110 abcdefg332

Sample Output 2:
There is 1 account and no account is modified

Sample Input 3:
2
team110 abcdefg222
team220 abcdefg333

Sample Output 3:
There are 2 accounts and no account is modified

题目大概意思是输入若干组账号密码,然后找出密码中1,l,0,O,将他们改成对应的字符,输出有几个需要改正,并输入改正后的账号密码,如果没有需要更改的,还要判断输入了几个账号密码,如果只有1个和有多个输出的英文不一样。
解题思路:每次输入账号密码之后遍历密码把需要修正的都改过来,然后把用户和密码拼接到一个字符串中加入到vector中,如果没有修改则不加入,最后判断vector中元素的个数如果不是零,就输出size和里面的元素,如果是零,再判断输入了几个用户输出对应的语句。

#include<iostream>
#include<vector>
using namespace std;

int main()
{
	int N,flag=0;
	vector<string> v;
	string name,password;
	cin>>N;
	for(int i=0;i<N;i++) {
		cin>>name>>password;
		for(int i=0;i<password.size();i++) {
			switch(password[i]) {
				case '1':password[i]='@';flag=1;break;
                case '0':password[i]='%';flag=1;break;
                case 'l':password[i]='L';flag=1;break;
                case 'O':password[i]='o';flag=1;break;
            }
        }
        if(flag==1) {
            string temp=name+" "+password;
            v.push_back(temp);
            flag=0;
        }
	}
	if(v.size()==0) {
		if(N==1) cout<<"There is 1 account and no account is modified";
		else cout<<"There are "<<N<<" accounts and no account is modified";
	}
    else {
		cout<<v.size()<<endl;
		for(int i=0;i<v.size();i++) cout<<v[i]<<endl;
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值