贪心算法C题

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.
在这里插入图片描述

Input
The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros

Output
For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. “-1” installation means no solution for that case.

Sample Input
3 2
1 2
-3 1
2 1

1 2
0 2
0 0

Sample Output
Case 1: 2
Case 2: 1

题意

如图,X轴上方是海,下方是陆地,在X轴上可以安放雷达,雷达的侦查范围半径为d,岛屿则在海面上,给定一系列岛屿坐标值(x,y),让你用最少的雷达覆盖尽可能多的岛屿,输出雷达的最少个数,如果不能全部覆盖则输出-1。

抽象模型

思路1:看岛在不在圆里面,如果以雷达所在位置为圆心画圆,以这种方式求,不好搞。该思路虽然看似能行,但是目前我写不出程序来,所以要换思路。

换位思考,如果以岛为圆心画圆呢?
思路2:以岛为圆心画圆,圆弧相交与X轴两点,如果雷达安放在这两点之间,那么岛就可被覆盖。
由此,将二维平面几何问题,转换成一维区间长度问题!!!
接下来,就是老套路了。
输入坐标时,判定一下岛是否可以被覆盖,如果有不可被覆盖的岛,则设置标记一下。
算出所有岛的相交于X轴的左右交点,存入数组,以右交点位置升序排序,
设置起始值为第一个岛的右交点位置,遍历数组,如果另一个岛的左交点大于起始值,则雷达数量加1,否则继续遍历。(实际上,雷达放置位置有多种)最后分两种情况输出即可。

AC

#include <iostream>
#include<algorithm>
#include<cmath>
#include<cstring>
using namespace std;
struct dao{
    double l,r;
}xd[1010];
bool cmp(dao a,dao b){
    return a.r<b.r;
}
double x,y;
int main(){
    int n,d;
    int ans=1;
    while(cin>>n>>d&&n!=0&&d!=0){
        int sum=1;
        bool pd=true;
        for(int i=0;i<n;i++){
            cin>>x>>y;
            if(y>d/*||d<0||y<0*/)
               pd=false;//判断能否被覆盖
            else{//计算以岛为圆心交于X轴的两交点位置
                double dx=sqrt(d*d-y*y);
                xd[i].l=x-dx;
                xd[i].r=x+dx;
            }
        }
        //单独输出
        if(!pd){cout<<"Case "<<ans++<<": -1"<<endl;continue;}
        sort(xd,xd+n,cmp);
        double t=xd[0].r;
        for(int i=1;i<n;i++){
            if(xd[i].l>t){
                sum++;
                t=xd[i].r;
            }
            /*else if(xd[i].r<t)
                t=xd[i].r;多余的*/
        }
        cout<<"Case "<<ans++<<": "<<sum<<endl;
    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值