贪心算法B题

A supermarket has a set Prod of products on sale. It earns a profit px for each product x∈Prod sold by a deadline dx that is measured as an integral number of time units starting from the moment the sale begins. Each product takes precisely one unit of time for being sold. A selling schedule is an ordered subset of products Sell ≤ Prod such that the selling of each product x∈Sell, according to the ordering of Sell, completes before the deadline dx or just when dx expires. The profit of the selling schedule is Profit(Sell)=Σx∈Sellpx. An optimal selling schedule is a schedule with a maximum profit.
For example, consider the products Prod={a,b,c,d} with (pa,da)=(50,2), (pb,db)=(10,1), (pc,dc)=(20,2), and (pd,dd)=(30,1). The possible selling schedules are listed in table 1. For instance, the schedule Sell={d,a} shows that the selling of product d starts at time 0 and ends at time 1, while the selling of product a starts at time 1 and ends at time 2. Each of these products is sold by its deadline. Sell is the optimal schedule and its profit is 80.

Write a program that reads sets of products from an input text file and computes the profit of an optimal selling schedule for each set of products.

Input
A set of products starts with an integer 0 <= n <= 10000, which is the number of products in the set, and continues with n pairs pi di of integers, 1 <= pi <= 10000 and 1 <= di <= 10000, that designate the profit and the selling deadline of the i-th product. White spaces can occur freely in input. Input data terminate with an end of file and are guaranteed correct.

Output
For each set of products, the program prints on the standard output the profit of an optimal selling schedule for the set. Each result is printed from the beginning of a separate line.

Sample Input
4 50 2 10 1 20 2 30 1
7 20 1 2 1 10 3 100 2 8 2
5 20 50 10

Sample Output
80
185

Hint
The sample input contains two product sets. The first set encodes the products from table 1. The second set is for 7 products. The profit of an optimal schedule for these products is 185.

题意

类似学生补作业那道题的思想,但不能照搬

商品有两个属性,利润和截止日期天数(类似寿命),一旦到截止日期就过期无法卖出,现有一系列商品,求最大利润。

输入
整数n,表示商品件数(0<=n<=10000)
然后n组数据pi、di,分别为利润和截止日期
(1<=pi,di<=10000)
连续输入多组数据,直到停止输入

输出
该组商品所能带来的最大利润之和

思路

贪心标准:
先按利润降序排序,选择当前利润最高的,并且标记该截止日期为已使用过,下一次日期若与该已使用的日期相同,则日期减1天;若不相同,则可以使用该未使用的日期,因此需要有一个数组来查找标记的日期

最佳AC

#include<iostream>
//#include<cmath>
#include<algorithm>
#include<cstring>
using namespace std;
int n,date[10001],sum;//截止日期数组
struct sp{
    int p,d;//利润、截止日期
}shop[10001];
bool cmp(sp a,sp b){//利润降序
    if(a.p>b.p)return true;
    else if(a.p<b.p)return false;
    return a.d<b.d;//截止日期小的尽可能放前面
}
int finddate(int x){
    if(date[x]==-1)return x;//未使用该日期
    return date[x]=finddate(date[x]);
    //查找下一个未使用的截止日期尽可能大的日期
}
int main(){
    while(cin>>n){
        memset(date,-1,sizeof(date));//标记-1为未使用,不能标为0
        //原因:会重复累加截止日期相同的商品利润
        //比如 d1=1 d2=1
        //第一次使用1后,date[1]=0
        //第二次再找1,由于date[1]=0,取反就为true了,导致return 1,从而t>0重复累加
        for(int i=0;i<n;i++)
            cin>>shop[i].p>>shop[i].d;
        sort(shop,shop+n,cmp);
        for(int i=0;i<n;i++){
            int t=finddate(shop[i].d);//查找日期
            if(t>0){
                sum+=shop[i].p;
                date[t]=t-1;//使用改日期后,需减1
            }
        }
        cout<<sum<<endl;
        sum=0;
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值