实验10-1 圆形体体积计算器 (20 分)

本题要求实现一个常用圆形体体积的计算器。
输入格式:
在每次计算之前,要求输出如下界面:

1-Ball
2-Cylinder
3-Cone
other-Exit
Please enter your command:

然后从标准输入读进一个整数指令。

输出格式:
如果读入的指令是1或2或3,则执行相应的体积计算;如果是其他整数,则程序结束运行。

当输入为1时,在计算球体体积之前,打印Please enter the radius:,然后读入球体半径,完成计算;
当输入为2时,在计算圆柱体体积之前,打印Please enter the radius and the height:,然后读入底圆半径和高,完成计算;
当输入为3时,在计算圆锥体体积之前,打印Please enter the radius and the height:,然后读入底圆半径和高,完成计算。
计算结果在一行内输出,保留小数点后两位。

输入样例:

1
2
3
2.4 3
0

输出样例:

1-Ball
2-Cylinder
3-Cone
other-Exit
Please enter your command:
Please enter the radius:
33.51
1-Ball
2-Cylinder
3-Cone
other-Exit
Please enter your command:
Please enter the radius and the height:
18.10
1-Ball
2-Cylinder
3-Cone
other-Exit
Please enter your command:

本来以为很简单的一道题,没想到的就是 pi 的精度为3.1415926535才可以通过第三个测试点…看到网上另一种表示 pi 的方法就是 #define pi acos(-1)

需要#include<math.h>

下为我写的:

#include <stdio.h>

double sp(double r);
double cy(double r, double h);
double f(double r, double h);
int main()
{
    int n;
    double r, h;
    while (1)
    {
        printf("1-Ball\n");
        printf("2-Cylinder\n");
        printf("3-Cone\n");
        printf("other-Exit\n");
        printf("Please enter your command:\n");
        scanf("%d", &n);
        if (n < 1 || n > 3)
        {
            break;
        }
        if (n == 1)
        {
            printf("Please enter the radius:\n");
            scanf("%lf", &r);
            printf("%.2f\n", sp(r));
        }
        else if (n == 2)
        {
            printf("Please enter the radius and the height:\n");
            scanf("%lf %lf", &r, &h);
            printf("%.2f\n", cy(r, h));
        }
        else if (n == 3)
        {
            printf("Please enter the radius and the height:\n");
            scanf("%lf %lf", &r, &h);
            printf("%.2f\n", f(r, h));
        }
    }
}
double sp(double r)
{
    double s;
    s = 3.1415926535 * r * r * r * 4 / 3; /* 乘号写在前, 除号写在后 */
    return s;
}
double cy(double r, double h)
{
    double s;
    s = 3.1415926535 * r * r * h;
    return s;
}
double f(double r, double h)
{
    double s;
    s = cy(r, h) / 3;
    return s;
}
  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

thoroughly strive

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值