02-线性结构4 Pop Sequence (25 分)

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, …, N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:
Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:
For each pop sequence, print in one line “YES” if it is indeed a possible pop sequence of the stack, or “NO” if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO

解释都在代码里

#include <stdio.h>

int main()
{
    int i, j, M, K, N;
    scanf("%d %d %d\n", &M, &K, &N);
    int stack[M];
    for (i = 0; i < N; i++)
    {
        int a[K], flag = 1;
        for (j = 0; j < K; j++)
        {
            scanf("%d", &a[j]);
        }
        int pstack = -1;//用一个数初值为 -1 代表栈顶下标
        int num = 1;//用 num 模拟顺序进栈数值
        int pool = 0;//所给数组下标
        while (pool < N)
        {
            if (pstack == -1)
            {
                stack[++pstack] = num; //栈空,按 1,2,3 的顺序进栈
                num++;
            }/*第一步判断栈是否为空,为空就按顺序压入数值*/
            else
            {
                if (stack[pstack] == a[pool])
                {//刚好匹配
                    pstack--; //栈顶标下移,数值出栈
                    pool++; //只有匹配栈内情况才能前移
                }
                else if (stack[pstack] < a[pool])
                {
                    if ((++pstack) == M)
                    {
                        flag = 0;
                        break;
                    }//入栈先判断栈是否是满的,因为栈顶和栈的容量刚好相差 1
                    stack[pstack] = num; //用一个num更新栈顶值,因为判断栈是否为满的时候栈顶下标已经自加过一次了,所以这里就不再加了
                    num++;
                }
                else
                { //如果栈顶的元素大于给的数,说明给的数还在栈里出不来,所以即给的顺序错误,直接退出
                    flag = 0;
                    break;
                }
            }
        }//这个循环其实就是在模拟入栈和出栈的过程
        if (flag)
        {
            printf("Yes\n");
        }
        else
            printf("No\n");
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

thoroughly strive

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值