7-14 电话聊天狂人 (25 分)

给定大量手机用户通话记录,找出其中通话次数最多的聊天狂人。

输入格式:
输入首先给出正整数N(≤10

5

),为通话记录条数。随后N行,每行给出一条通话记录。简单起见,这里只列出拨出方和接收方的11位数字构成的手机号码,其中以空格分隔。

输出格式:
在一行中给出聊天狂人的手机号码及其通话次数,其间以空格分隔。如果这样的人不唯一,则输出狂人中最小的号码及其通话次数,并且附加给出并列狂人的人数。

输入样例:

4
13005711862 13588625832
13505711862 13088625832
13588625832 18087925832
15005713862 13588625832
**结尾无空行**

输出样例:

13588625832 3
**结尾无空行**

我决定有时间就刷一下PTA上的算法题吧,最近找到一个cpp的网站,挺适合我来学习stl的,nice

#include <algorithm>
#include <iostream>
#include <unordered_map>
#include <vector>
using namespace std;
bool cmp(const pair<string, int> &a, const pair<string, int> &b)
{
    if (a.second == b.second)
    {
        return a.first < b.first;
    }
    else
    {
        return a.second > b.second; //为假,就把大的 b 与 a 做交换,大的在前面,小的在后面,从大到小排序
    }
}
int main()
{
    unordered_map<string, int> sum;
    int n, i;
    string from, to;
    cin >> n;
    for (i = 0; i < n; i++)
    {
        cin >> from >> to;
        sum[from]++;
        sum[to]++;
    }
    vector<pair<string, int>> s;
    for (unordered_map<string, int>::iterator it = sum.begin(); it != sum.end(); it++)
    {
        s.emplace_back(*it);
    }
    sort(s.begin(), s.end(), cmp);
    cout << s.begin()->first << " " << s.begin()->second;
    int cnt = 1;
    /*s.end()指向最后一个元素的下一个元素的地址,不是空指针,只是没有内容*/
    for (vector<pair<string, int>>::iterator it = next(s.begin()); it != s.end(); it++)
    {
        if (it->second == s.begin()->second)
        {
            cnt++;
        }
        else
        {
            break;
        }
    }
    if (cnt > 1)
    {
        cout << " " << cnt << endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

thoroughly strive

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值