POJ - 3104

Drying POJ - 3104

  • It is very hard to wash and especially to dry clothes in winter. But Jane is a very smart girl. She is not afraid of this boring process. Jane has decided to use a radiator to make drying faster. But the radiator is small, so it can hold only one thing at a time.

    Jane wants to perform drying in the minimal possible time. She asked you to write a program that will calculate the minimal time for a given set of clothes.

    There are n clothes Jane has just washed. Each of them took ai water during washing. Every minute the amount of water contained in each thing decreases by one (of course, only if the thing is not completely dry yet). When amount of water contained becomes zero the cloth becomes dry and is ready to be packed.

    Every minute Jane can select one thing to dry on the radiator. The radiator is very hot, so the amount of water in this thing decreases by k this minute (but not less than zero — if the thing contains less than k water, the resulting amount of water will be zero).

    The task is to minimize the total time of drying by means of using the radiator effectively. The drying process ends when all the clothes are dry.

Input

  • The first line contains a single integer n (1 ≤ n ≤ 100 000). The second line contains ai separated by spaces (1 ≤ ai ≤ 109). The third line contains k (1 ≤ k ≤ 109).

Output

  • Output a single integer — the minimal possible number of minutes required to dry all clothes.

Sample Input

  • sample input #1
    3
    2 3 9
    5
    
    sample input #2
    3
    2 3 6
    5
    

Sample Output

  • sample output #1
    3
    
    sample output #2
    2
    

题目大意

  • 衣服自然烘干的脱水速度是1,使用烘干机的脱水速度是k,但烘干机每次只能烘干一件衣服,求出烘干所有衣物的最小时间。
  • 一道二分的题,二分时间,右端点是所有衣物中的最大含水量
#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cmath>
#include<cstring>
using namespace std;
typedef long long ll;
ll a[100005];
ll k;
ll n;
bool judge(ll mid){//二分思路:如果每件衣服含水量均小于预期时间mid,则mid可行,当含水量大于mid时,作差以获得含水量差值,对应除以k与自然烘干速度的差值(k-1),得到对于这件衣服所需要使用烘干机的时间
	ll sum=0;
	for(int i = 0;i<n;i++){
		if(a[i]>mid){//如果第i件衣服的含水量大于预期所用时间时,考虑使用烘干机
			sum+=ceil((a[i]-mid)*1.0/(k-1));//这里的k-1可以理解为使用烘干机的同时也在风干,则k-1为真正烘干机烘干的水分
		}
		if(sum>mid) return true;
	}
	
	 return false;
}
int main(){
	while(~scanf("%lld",&n)){
		ll r = 0;
	for(int i = 0 ;i< n ;i++){
		scanf("%lld",&a[i]);
		r = max(r,a[i]);
	}

	scanf("%lld",&k);
	ll l = 1 ;

	ll mid;
	if(k == 1){
		printf("%lld\n",r);
		continue;
	}//特判当烘干机的烘干速度与自然风干速度相同的情形,直接输出最大含水量即可。
	while(l<r){
		mid = (l+r)>>1;
		if(judge(mid)){//mid不可行,增大mid
			l = mid+1;
		}
		else{
			r = mid;//mid可行,继续缩小mid以获得最优解
		}
	}
	printf("%lld\n",r);
}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值