POJ - 2785

4 Values whose Sum is 0 POJ - 2785

  • The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .

Input

  • The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 228 ) that belong respectively to A, B, C and D .

Output

  • For each input file, your program has to write the number quadruplets whose sum is zero.

Sample Input

6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45

Sample Output

5

题目大意

  • 给出n组A,B,C,D四个数,求出能够满足A+B+C+D=0的组合的数量
  • 这道题简单的遍历四组数字求出所有加法组合必然超时,因此先分别求出A+B与C+D的所有结果放入数组当中,在一个数组中搜索另一个数组中每个元素的相反数即可。
#include<iostream>
#include<algorithm>
#include<cstdio>
using namespace std;
typedef long long ll;
ll a[4005],b[4005],c[4005],d[4005],sum1[4005*4005],sum2[4005*4005];
int main(){
	int n;
	cin>>n;
	for(int i = 0;i<n;i++){
		scanf("%lld %lld %lld %lld",&a[i],&b[i],&c[i],&d[i]);
	}
	ll k = 0;
	for(int i = 0;i<n;i++){
		for(int j = 0;j<n;j++){
			sum1[k]=a[i]+b[j];
			sum2[k]=c[i]+d[j];
			k++;
		}
	} 
	sort(sum1,sum1+k);
	int ans = 0;
	for(int i = 0;i<k;i++){
		ll num = lower_bound(sum1,sum1+k,-sum2[i])-sum1; 
		if(sum1[num]== -sum2[i]){
			ans+= upper_bound(sum1,sum1+k,-sum2[i])-sum1 - num; //上下界作差,有可能同一个sum1中的元素在sum2中有多组答案相匹配。
		}
	}
	
	printf("%d",ans);
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值