题目描述
读入一个只包含 +, -, *, / 的非负整数计算表达式,计算该表达式的值。
输入
测试输入包含若干测试用例,每个测试用例占一行,每行不超过200个字符,整数和运算符之间用一个空格分隔。没有非法表达式。
当一行中只有0时输入结束,相应的结果不要输出。
输出
对每个测试用例输出1行,即该表达式的值,精确到小数点后2位。
样例输入
1 + 2
4 + 2 * 5 - 7 / 11
0
样例输出
3.00
13.36
详见代码
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <vector>
#include <set>
#include <queue>
#include <stack>
#include <math.h>
#include <cmath>
#include <string.h>
#include <string>
using namespace std;
typedef long long ll;
const int N = 1e5+10;
stack<char> so;
stack<double> sn;
int main()
{
double a;
while(scanf("%lf",&a)&&a!=0){
// printf("%.0f",a);
sn.push(a);
char bla;//空格 或 回车
while(scanf("%c",&bla)&&bla!='\n'){
double b;char c;
scanf("%c %lf",&c,&b);
// printf(" %c %.0f",c,b);
double l;
if(c=='*'){
l = sn.top();sn.pop();
sn.push(l*b);
}else if(c=='/'){
l = sn.top();sn.pop();
sn.push(l/b);
}else if(c=='+'){
sn.push(b);
so.push(c);
}else{
sn.push(-b);//为了后续从后计算不出错
so.push('+');
}
}
while(sn.size()>1){
double l,r;
char op = so.top();so.pop();
r = sn.top();sn.pop();
l = sn.top();sn.pop();
// printf("l==%.2f r==%.2f\n",l,r);
sn.push(l+r);
}
printf("%.2f\n",sn.top());sn.pop();
}
return 0;
}