Dire Wolf(区间DP)

原题:
Dire wolves, also known as Dark wolves, are extraordinarily large and powerful wolves. Many, if not all, Dire Wolves appear to originate from Draenor.
Dire wolves look like normal wolves, but these creatures are of nearly twice the size. These powerful beasts, 8 - 9 feet long and weighing 600 - 800 pounds, are the most well-known orc mounts. As tall as a man, these great wolves have long tusked jaws that look like they could snap an iron bar. They have burning red eyes. Dire wolves are mottled gray or black in color. Dire wolves thrive in the northern regions of Kalimdor and in Mulgore.
Dire wolves are efficient pack hunters that kill anything they catch. They prefer to attack in packs, surrounding and flanking a foe when they can.
— Wowpedia, Your wiki guide to the World of Warcra

Matt, an adventurer from the Eastern Kingdoms, meets a pack of dire wolves. There are N wolves standing in a row (numbered with 1 to N from left to right). Matt has to defeat all of them to survive.

Once Matt defeats a dire wolf, he will take some damage which is equal to the wolf’s current attack. As gregarious beasts, each dire wolf i can increase its adjacent wolves’ attack by bi. Thus, each dire wolf i’s current attack consists of two parts, its basic attack ai and the extra attack provided by the current adjacent wolves. The increase of attack is temporary. Once a wolf is defeated, its adjacent wolves will no longer get extra attack from it. However, these two wolves (if exist) will become adjacent to each other now.

For example, suppose there are 3 dire wolves standing in a row, whose basic attacks ai are (3, 5, 7), respectively. The extra attacks bi they can provide are (8, 2, 0). Thus, the current attacks of them are (5, 13, 9). If Matt defeats the second wolf first, he will get 13 points of damage and the alive wolves’ current attacks become (3, 15).

As an alert and resourceful adventurer, Matt can decide the order of the dire wolves he defeats. Therefore, he wants to know the least damage he has to take to defeat all the wolves.
Input
The first line contains only one integer T , which indicates the number of test cases. For each test case, the first line contains only one integer N (2 ≤ N ≤ 200).

The second line contains N integers ai (0 ≤ ai ≤ 100000), denoting the basic attack of each dire wolf.

The third line contains N integers bi (0 ≤ bi ≤ 50000), denoting the extra attack each dire wolf can provide.
Output
For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1), y is the least damage Matt needs to take.
Sample Input
2
3
3 5 7
8 2 0
10
1 3 5 7 9 2 4 6 8 10
9 4 1 2 1 2 1 4 5 1
Sample Output
Case #1: 17
Case #2: 74

Hint
In the first sample, Matt defeats the dire wolves from left to right. He takes 5 + 5 + 7 = 17 points of damage which is the least damage he has to take.

题意:

通过杀狼而使自己受到的最小。而这里的变量就是额外伤害。

思路:

因为这个额外伤害是变量,它随着我们啥的狼的位置他的额外的伤害就会变化。所以找到额外伤害之间的关系就是我们的解题的关键。刚开始我是找规律来解这个题,因为事先知道他是区间dp所以我就用从dp[1][1]、dp[1][2]、dp[1][3]。这种方法能够找到他的规律来,但是有的时候你不知道他需要怎么组合。那么我们来想这个题,他让求从1~n最小的承受伤害,他的上一步是在k处由两个子区间合并成这个整区间,那么杀死这个第k只狼需要承受的伤害是多少?arr[k]+brr[i-1]+brr[j+1]。那么状态方程就出来了。
dp[i][j]=min(dp[i][j],dp[i][k-1]+dp[k+1][j]+arr[k]+brr[i-1]+brr[j+1])
找规律法和分成子区间在合并法两种方法一起用应该还是蛮好找状态方程的。

ac代码:
#include <iostream>
#include <iomanip>
#include <cstdio>
#include <cstring>
#include <string>
#include <vector>
#include <map>
#include <algorithm>
#include <queue>
#include <stack>
#include <cmath>
#define inf 0x3f3f3f3f
#define ll long long
using namespace std;
const int  maxn=1e5+10;
string a,b;
int dp[210][210],ans[110],arr[220],brr[220];
int main()
{
	int t,a=0;
	cin>>t;
	while(t--)
    {a++;
        int n;
        cin>>n;
        memset(arr,0,sizeof(arr));
        memset(dp,0,sizeof(dp));
        memset(brr,0,sizeof(brr));
        for(int i=1;i<=n;i++)
            cin>>arr[i];
        for(int i=1;i<=n;i++)
            cin>>brr[i];
            for(int i=1;i<=n;i++)
                dp[i][i]=arr[i];
        for(int len=1;len<=n;len++)
        {
            for(int i=1,j=len;j<=n;i++,j++)
            {
                dp[i][j]=inf;
                for(int k=i;k<=j;k++)
                    dp[i][j]=min(dp[i][j],dp[i][k-1]+dp[k+1][j]+brr[i-1]+brr[j+1]+arr[k]);

            }
        }
cout<<"Case #"<<a<<": ";
        cout<<dp[1][n]<<endl;
    }
}

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

晨晓翔同学

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值